Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

1. Вычислить корни квадратного уравнения ax²+bx+c=0? заданного коэффициентами а, b, с (предполагается, что а не равно 0 и что дискриминант уравнения

10-11 класс

неотрицательный).
2. Найти сумму членов арифметической прогрессии, если известны первый член, знаменатель и число членов прогрессии.
В ПАСКАЛЕ ВСЕ

Tyulen4636641 30 сент. 2016 г., 1:25:17 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Akshdima2008
30 сент. 2016 г., 2:39:34 (7 лет назад)

1)
Var a,b,c:integer; x1,x2,d:real;
Begin
 write('a='); readln(a);
 write('b='); readln(b);
 write('c='); readln(c);
 d:=sqr(b)-(4*a*c);
 x1:=(-b+sqrt(d))/(2*a);
 x1:=(-b-sqrt(d))/(2*a);
 writeln('x1=',x1:0:2);
 writeln('x2=',x2:0:2);
End.

2)
Var x,i,s,n,d:integer;
Begin
 write('Введите первый элемент прогрессии: '); readln(x);
 write('Введите количество элементов в прогрессии: '); readln(n);
 write('Введите знаменатель прогрессии: '); readln(d);
 s:=0;
 for i:=1 to n do
   begin
    s:=s+x;
    x:=x+d;
   end;
 writeln('Сумма элементов арифметической прогрессии равна ',s);
End.

+ 0 -
Chery28
30 сент. 2016 г., 3:47:26 (7 лет назад)

1).D=b2-4ac, D>O.

Ответить

Другие вопросы из категории

помогите пожалуйста решить задачу в кумире.

Определить по паре переменных всех типов. Присвоить переменным произвольные
значение, соответствующих их типу. Присвоить одной из переменных каждого типа результаты
применения операции сложения/прибавления/объединения в зависимости от типа данных.
Произвести операции разности, умножения и деления над числовыми переменными. Присвоить
логическим переменным результат сравнения суммы и произведения (что больше?) и разности и
деления (что меньше?).

Пожалуйста, помогите решить задачу.

Предположим, что длительность непрерывного подключения к сети Интернет с помощью модема для некоторых АТС не превышает 10 минут. Определите максимальный размер файла в Кбайтах, который может быть передан за время такого подключения, если модем передает информация в среднем со скоростью 32 килобита/с.

обчисліть значення логічних виразів для Х=5; Y=10.

а) not (X<=Y);
б) (X<>Y) or not (X - 1 = Y)



Вы находитесь на странице вопроса "1. Вычислить корни квадратного уравнения ax²+bx+c=0? заданного коэффициентами а, b, с (предполагается, что а не равно 0 и что дискриминант уравнения", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.