Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Программу на Си. Найти

10-11 класс

все трехзначные числа, сумма цифр которых равна данному целому числу.

Nikitinaanzhel 01 сент. 2013 г., 23:41:17 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Lbvj
02 сент. 2013 г., 1:19:49 (10 лет назад)

#include <stdio.h>
int main()
{
    int a;
    scanf("%d", &a);
    for(int i = 100;i < 1000;i++)
    {
        if((i % 10 + ((i % 100 - i % 10) / 10) + (((i- i % 10 ) / 10) - i % 10) / 10)) == a)
        {
            printf("%d", i);
        }
    }
}



Правда это слегка кустарный способ решения

Ответить

Другие вопросы из категории

Пожалуйста назовите (это по информатике) 1)устройства обработки информации,

2)устройства передачи информации,
3) устройства мультимедийной обработки информации.

Платону, Аристотелю и Еврипиду предъявлено обвинение в ограблении сборщика налогов. Грабители скрылись организованно. На следствии Платон

показал, что преступники скрылись на синей колеснице, Аристотель сказал, что это был черный скакун, а Еврипид утверждал, что это был ишак и ни в коем случае не синий. Стало известно, что желая запутать следствие, каждый из них указал правильно либо транспортное средство, либо только его цвет. На каком транспортном средстве и какого цвета скрылись грабители?

Читайте также

№1. Дан массив из 30-ти элементов. Каждый элемент может принимать целочисленные значения от 0 до 100. Напишите программу, которая позволит найти сумму

двузначных элементов массива, которые не оканчиваются на 3. №2. Дан массив из 100 элементов. Каждый элемент может принимать целочисленные значения от 1 до 500. Напишите программу, которая позволит найти и вывести минимальное значение среди элементов массива, которые делят максимальное значение элементов массива без остатка.

написать программу на Assembler

добрый вечер, всем. помогите, пожалуйста, написать программу на Ассемблере.

задание:
Создать программу на языке Ассемблер, что позволяет организовать вычисления над элементами массивов

Объединить два массива 8-битных целых чисел со знаком. Сначала элементы второго затем первого.

заранее огромное спасибо всем!

программа на C++ в визуальном режиме (есть несколько вариантов кода программы)

доброй ночи, уважаемые программисты и успевающие в учебе студенты. помогите, пожалуйста, написать программу на C++ (в визуальной вкладке).

ВОТ ЗАДАНИЕ:
дано три переменные вещественного типа. если их значения упорядочены по возрастанию или убыванию, то удвоить их; иначе заменить значение каждой переменной на противоположное. вывести значения переменных.


я прикрепила несколько тестовых файлов (блокнот) в которых есть несколько вариантов решение этого задание (то есть коды программ), а вы скажите какой из них лучше всего подходит, а также скажите какие компоненты нужно кинуть на форму-дизайн (то есть какие кнопки, и что на них писать). в этих 3 файлов есть написанный код программы, нужно написать: на какие кнопки что писать и какой вариант решение больше подходит.

заранее огромное спасибо всем за помощь!!!

1) Напишите пожалуйста программу (на языке BASIC) вычисления по длинам двух сторон треугольника и углу между ними длины третьей стороны и двух других

углов.
2)
Напишите пожалуйста программу (на языке BASIC) для определения подобия:
а) двух прямоугольников по двум смежным сторонам;
б) двух треугольников по трем сторонам.



Вы находитесь на странице вопроса "Программу на Си. Найти", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.