Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

С1. Составить алгоритм

5-9 класс

и написать программу на вычисление площади или периметра прямоугольника
, при условии, если а < b ,
тогда вычисляем периметр , иначе площадь . Каждую строку программы прокомментировать .
Входные данные а=10 , b=8
помогите решить 9 класс

KomarikS 06 апр. 2014 г., 3:26:13 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Asseldiplomat
06 апр. 2014 г., 5:44:20 (10 лет назад)

Более красивый вариант) 

Program N_1;                         //Название программы
Var a,b,c:integer;                   //Переменные
BEGIN
Writeln('Введите длину и ширину прямоугольника');  //Вывести данную строку
readln(a,b);                         //Считать a и b
if a<b                                 //Если a<b
then begin                          //то найти периметр
c:=(a+b)*2;
Writeln('Пириметр= ',c)       //и вывести его
end
else begin                         //Если a>b
c:=a*b;                             //то найти площадь
writeln('Площадь= ',c)       //и вывести ее.
end;
END.

+ 0 -
LebronKing
06 апр. 2014 г., 6:45:07 (10 лет назад)

Какой язык?

+ 0 -
Mandzyukn
06 апр. 2014 г., 8:03:03 (10 лет назад)

не знаю но информатика 9 класс

+ 0 -
Yana0119
06 апр. 2014 г., 10:31:11 (10 лет назад)

Ты даже не знаешь какой язык вы изучаете?)

+ 0 -
Hfgt
06 апр. 2014 г., 11:27:03 (10 лет назад)

информатика

Ответить

Другие вопросы из категории

Напишите программу, которая сравнивает два числа: 2 в степени 100 и 3 в степени 50. Программа должна выводить слово "больше", если первое число больше

второго, "равно" — если числа равны, "меньше" — если первое число меньше второго. Сами числа выводить не нужно.

Читайте также

Составить алгоритм нахождения площади и длины окружности если известен радиус.

Составить алгоритм нахождения площади и длины окружности если известен диаметр.

Умоляю помогите,мне нужно составить Алгоритм своего имени ,зовут меня Нурлан

Мне необходимо составить алгоритм каждой буквы : н,у,р,л,а,н
Примерно алгоритм выглядит вот так- Поднять перо. Сместиться в точку.Опустить перо.Сместиться на вектор.
Составьте хотя бы алгоритм буквы Н

1) Составить алгоритм выхода на улицу в зависимости от погодных условий.

2)Составить алгоритм кипячения воды а чайнике с помощью электроплиты.

Пожалуйста,мне нужно составить Алгоритм своего имени по Информатике

Алгоритм выглядит примерно так- Сместиться в точку ....
Опустить перо
Сместиться на вектор ...

Моё имя-Нурлан
Пожалуйста кто сможет напишите ) Заранее большое спасибо вам

Составьте алгоритм вычисления суммы всех

натуральных чисел, не превышающих заданного натурального числа N.
Проверьте алгоритм трассировкой. Напишите программу на Паскале.



Вы находитесь на странице вопроса "С1. Составить алгоритм", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.