Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

Ввести стоимость покупки в магазине, если стоимость меньше тысячи, то вывести "скидки нет", если стоимость от 1000 до 5000, то вывести "скидка 5%",

5-9 класс

если стоимость свыше 5000, то вывести "скидка 10%". Вывести сумму со скидкой.

Kundana 26 марта 2017 г., 19:38:22 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Delfin8
26 марта 2017 г., 21:36:22 (7 лет назад)

Для Paskal ABC
Program magazin;
var
     a:integer;
     s:integer;
begin
s:=0;
writeln('Введите стоимость:');
readln(a);
If a<1000 then begin 
writeln('Скидок нет'); 
 writeln('Ваша сумма:',a);end;
If (a>=1000)and(a<=5000) then begin 
   s:=(a/100)*95;   
writeln('Ваша скидка 5%');   
 writeln('Ваша сумма:',s);end;
If a>5000 then begin 
 s:=(a/100)*90;   
writeln('Ваша скидка 10%'); 
 writeln('Ваша сумма:',s);end;

Ответить

Другие вопросы из категории

Ребят помогите срочно надо!!! Расположить девять последовательных шестнадцатеричных чисел от А16 до 1216 (16- системы счисления). В

квадрате размером 3*3 клетки таким образом, чтобы сумма чисел по каждой строке, каждому столбцу и диагоналям была одинаковой, и указать эту сумму в шестнадцатеричной системе счисления. Заранее спасибо.

Файл размером 8 кбайт передается через соединение со скоростью 4096 бит в секунду.

Определите размер файла (в байтах),который можно передать за это же время через другое соединение со скоростью 256 бит в секунду.

Читайте также

Если покупатель в магазине покупает товары от 1000 до 2000 то получает 5 % скидку,а если от 2000 то получает 10% Исходя из данных составить эл.

таблицу. А - И.Ф. покупателя В - стоимость покупки С - оплата (формула только в "оплата",там нужно через =если...)

Определить стоимость покупки с учетом скидки . Скидка в 10% предоставляется если сумма покупки больше 1000 рублей. Входные данные S-стоимость покупки.

ВХОДНЫЕ ДАННЫЕ S- стоимость покупки с учетом скидки( если она предоставляется)

Пожалуйста помогите!! очень срочно, нужно написать программу скорей всего мне кажется в паскале

1. Writel(' вести стоимость перчатки наприм')
read (x)
2 стоимость сумки- наприм.
3.стоимость ремня- наприм.
4.если общая сумма больше 800р, то вывести сумму с учетом 10% скидки
5.если сумма меньше 800р, то вывести сумму
Помогите пожалуйста очень нужно, благодарю!!!



Вы находитесь на странице вопроса "Ввести стоимость покупки в магазине, если стоимость меньше тысячи, то вывести "скидки нет", если стоимость от 1000 до 5000, то вывести "скидка 5%",", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.