Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

Пожалуйста решите и составьте программу на языке Паскаль. В равнобедренной трапеции стороны а и b, угол при основании равен 60 градусов. Найдите

5-9 класс

площадь, периметр.

Nastyhigh 19 февр. 2017 г., 6:50:58 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Geracal
19 февр. 2017 г., 9:06:20 (7 лет назад)

во первых, если трапеция равнобедренная, то для нее можно найти высоту, но для этого нужно сначала найти кусочек, который будет стороной для треугольника с углом 60 градусов.
Итак, сторона треугольника x = (b-a)/2, Теперь высота это h = x *tg 60. но в Паскаль функции тангенс нет, поэтому выражаем (и углы переводим в радианы)   h = x * sin(60*3.14/180)/cos (60*3.14/180)/
теперь сама программа:
Var a/ b, x,h, S, P: real;
k: integer;
begin
read (a,b);
x:= abs(b-a)/2);
h:= x* sin (k*3.14/180)/cos(k*3.14/180);
S:= 0.5*(a+b)*h;
P:= 2*h+a+b;
Writeln ('S=', S:5:2, 'P=', P:5:2);
end.

Если взять значения, которые легко построить для проверки: b= 7, a= 3 для угла 60 градусов, то получим h = 3.4 S = 17.30, P= 16, 92 
 как то так. удачи

Ответить

Другие вопросы из категории

Что такое double в информатике?
Помогите пожалуйста с инфой Определите, по какой из масок из них будет отобрана указанная группа файлов:

bike.mp3
like.mpg
mikes.mp3
nike.mpeg

Варианты ответов:

1)​?ik*.m*​2)​?ik*.mp?​3)​*ik?.mp*​4)​?ik*.mp*

Помогите решить с объяснением
Помогите пожалуйста с информатикой!

Постройте отрицания следующий высказываний

1.Сегодня в театре идет опера "Евгений Онегин"

2.Каждый охотник желает знать, где сидит фазан

Читайте также

Помогите, пожалуйста, очень нужно! Срочно!:( 1) Не используя функцию возведения в квадрат, напишите на языке Паскаль наиболее короткие алгоритмы

вычисления: а) y=x^10 б) y=x^15. Постараться использовать минимальное количество дополнительных переменных. 2) Дана сторона равностороннего треугольника. Найти площадь этого треугольника, его высоты, радиусы вписанной и описанной окружностей. Программу записать на языке Паскаль. 3) Дана величина А, выражающая объём информации в байтах. Перевести А в более крупные единицы измерения информации. Программу записать на языке Паскаль

Плиз срочно надо.1)Найдите правильную на языке паскаль запись выражения

19(16,3+7,7).а)19(16.3+7.7),в)19*(16.3+7.7).д)19(16,3+7.7).с)19*(16.3+7.7).2)Найдите правильную на языке паскаль записы выражения \frac{34,5+24,5}{15y}.а)34.5+24.5/15у в)(34.5+24.5)/15у с)(34.5+24.5)15*у.д)(34.5+24.5)/(15*у).3)Вычислите длину окружности и площадь круга одного и того же заданного радиуса R.4)Даны два числа.Найдите среднее арифметическое кубов этих чисел и среденее геометрическое модулей этих чисел.Два последних номера там нужно написать программу,программу присылать на листочке

Составить программу на языке Паскаль

Вывести на экран таблицу соответствия между весом в фунтах и весом в кг для значений от 1 до 20 с шагом 1 фунт (1 фунт=400г)
Пример оформления результата:
1 фунт=0,4 кг
2 фунт=0,8 кг
....
20 фунт=8 кг



Вы находитесь на странице вопроса "Пожалуйста решите и составьте программу на языке Паскаль. В равнобедренной трапеции стороны а и b, угол при основании равен 60 градусов. Найдите", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.