Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Помогите пожалуйста!!! Составить алгоритм ( на русском языке)

5-9 класс

1. Татьяна Ларина, читая очередной фрацузский роман, подсчитала сумму номеров прочитаных страниц. Обозначив эту сумму Q. Напишите программу, определяющую номер последней прочитанной страницы.

Hululu 15 марта 2014 г., 18:34:53 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Striz
15 марта 2014 г., 19:17:35 (10 лет назад)

program tan9;

var Q,n,m:integer;

begin

writeln ('Vvedit sumu stranic');

readln (Q);

n:=0; m:=0;

while m=Q do

begin

m:=n+m 

n:=n+1; 

end;

writeln ('posledn99 prochitana9 stranica-',n);

readln

end.

 

Это Pascal(будут вопросы пиши) 

Ответить

Другие вопросы из категории

Какие источники информации использовали следующие персонажи сказок А. С. Пушкина: 1) царевич Елисей, искавший свою невесту; 2) злая мачеха, задумавшая

извести свою падчерицу и доверявшая только одному источнику информации; 3) царь Салтан, чтобы узнать о дальних странах; 4) царевич Гвидон, чтобы узнать о диковинках; 5) царь Дадон, чтобы узнать о набегах врагов?

1 В корзине 77g фруктов 32 яблока 22g мандарина 6g апельсинов 15g слив в какой системе счисления посчитаны фрукты 1. 7 2.8 3.9

4.2

2 Программа уплотняющие файлы называют??

1.утилита

2.архиватор

3.резидентными

4.знаковыми

3

На репетиции новогоднего представления на поклон вышли все участники в следующем порядке: енот, ежик, лиса, заяц, медведь, волк?Режиссер попросил всех построиться по росту: медведь, волк, лиса, заяц, енот, ежик, но разрешил перестраиваться в ряду, меняясь местами только рядом стоящими парами и переходить на новое место, проходя также по ряду рядом со стоящими парами. За какое наименьшее число таких переходов можно перестроиться по росту??

Читайте также

Автоматическое устройство осуществило перекодировку информационного сообщения на русском языке, первоначально записанного в 16-битном коде Unicode, в 8-ми

битную кодировку Windows-1251, при этом информационный объем сообщения составил 60 байт. Определите информационный объем (в битах) сообщения до перекодировки.

Помогите пожалуйста!!)

ПОМОГИТЕ ПОЖАЛУЙСТА СОСТАВИТЬ ПЛАН ЭТОГО ПАРАГРАФА! § 2.2. Информационные модели Объект-оригинал можно заменить набором его свойств: названий (величин)

и значений. Набор свойств, содержащий всю необходимую информацию об исследуе¬мых объектах и процессах, называют информационной моделью.
В табл. 2.1 приведен пример информационной модели дачного дома — карточка из каталога, по которому заказ¬чик строительной компании может выбрать подходящий проект. Каждая карточка в каталоге содержит названия (величины) свойств дома (слева) и значения этих свойств (справа).

Таблица 2.1

Внешний вид
Длина 10 м
Ширина 8 м
Количество этажей 1
Материал стен Кирпич
Толщина стен 0,6 м
Внутренняя отделка стен Доска
Материал крыши Шифер

Все названия свойств в информационных моделях — это всегда знаковые элементы, потому что название может быть выражено только знаками. А вот значения величин могут нести как знаковую, так и образную информацию. Например, в табл. 2.1 значение величины «внешний вид» выражено образным элементом (рисунком), а значения остальных величин выражены с помощью знаков (чисел, слов, запятых).
Образным элементом информационной модели может быть не только рисунок или фотография, но и объемный макет или видеозапись. Однако при этом обязательно дол¬жна иметься возможность связать этот элемент с характе¬ристикой конкретного объекта. Например, в строке «Внешний вид» в каталоге домов может быть указан шифр макета. А чтобы сами макеты были элементами ин¬формационной модели, а не украшением, их нужно снаб¬дить ярлыками с шифрами.
Информационные модели представляют объекты и процессы в образной или знаковой форме. По способу представления различают следующие виды информацион¬ных моделей — рис. 2.1.

Виды информационных моделей


Образные Смешанные Знаковые
модели модели модели


Карты Графы Блок-схемы

Рис. 2.1

Образные модели (рисунки, фотографии и др.) пред-ставляют собой зрительные образы объектов, зафиксиро¬ванные на каком-либо носителе информации (бумаге, фо¬то- и кинопленке и др.).
Много информации дают специалистам полученные со спутников фотографии поверхности Земли (рис. 2.2)


Рис. 2.2 Полученная со спутника фотография территории в районе Чёрного моря<

Широко используются образные информационные мо¬дели в образовании (иллюстрации в учебниках (рис. 2.3), учебные плакаты по различным предметам) и науках, где требуется классификация объектов по их внешним при¬знакам (в ботанике, биологии, палеонтологии и др.).

Рис. 2.3 Построение римского легиона в три линии

Знаковые информационные модели строятся с исполь-зованием различных языков (знаковых систем). Знаковая информационная модель может быть представлена в фор¬ме текста на естественном языке или программы на языке программирования, формулы (например, площади прямо-угольника S = ab) и т. д.
Во многих моделях сочетаются образные и знаковые элементы. На рис. 2.4 приведен пример модели однокле¬точной водоросли хламидомонады. Нарисованные части водоросли — образные элементы этой модели, а надписи снизу и справа от рисунка — знаковые элементы. Рис. 2.4

Примерами смешанных информационных моделей могут служить географические карты, графики, диаграм¬мы и пр. Во всех этих моделях используются одновремен¬но и графические элементы, и символьный язык.


і Коротко о главном
Объект-оригинал можно заменить набором его свойств: их названий и значений. Набор свойств, содержа¬щий всю необходимую информацию об исследуемых объ¬ектах и процессах, называют информационной моделью.
Информационные модели представляют объекты и процессы в образной или знаковой форме. По способу представления различают образные, знаковые и смешанные информационные модели.

1.Составьте блок-схему для решения задачи: Найти площадь S и периметр P прямоугольника. Значения сторон а и в задать произвольно.

2.Составить блок - схему кипячения чайника.

3.Составить алгоритм сбора яблок в саду.Ваша задача сводится к тому,что необходимо собрать ведро яблок с земли.

4.Составьте алгоритм на формальном языке и блок - схему для решения следущего примера : y=5x+6,если х=3



Вы находитесь на странице вопроса "Помогите пожалуйста!!! Составить алгоритм ( на русском языке)", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.