Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Помогите решить!!! Уже всю голову сломал, думая над этой задачей.

10-11 класс

Если город представить в виде двумерного массива, то получается, что в каждом квартале (ячейке массива) может стоять либо Маша, либо камера (или несколько камер). Посчитать манхтэнское расстояние(сумма расстояний от Маши до всех камер) по формуле:
R= |x1-x2|+|y1-y2|.
Первоначальные координаты Маши (0,0).
Формат ввода:
Первая строка содержит N кол-во камер в городе и M шагов Маши. Вторая строка - координаты камер (х,y).
Для описания передвижения Маши с клавиатуры вводится символы U,D,R,L. Каждый из них означает:
U- увеличить координату у на 1.
D - уменьшить эту же координату.
L - уменьшить координату х.
R - увеличить координату х.
Выводить манхтэнское расстояние для каждого шага Маши.
Пример:
Ввод:___ Вывод:
1 3_______11
0 -10_____12
RUR _____13

Somovvanechka1 24 авг. 2014 г., 11:14:52 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Uylana09102003
24 авг. 2014 г., 13:08:40 (9 лет назад)

program gt;
var p,j,n,m,x,y,i:integer;
a,b:array[1..1000]of integer;
s:char;
begin
readln(n,m);
for i:=1 to n do
read(a[i],b[i]);
x:=0;y:=0;
for i:=1 to m do
begin
read(s);
if(s='U')then y:=y+1;
if(s='D')then y:=y-1;
if(s='L')then x:=x-1;
if(s='R')then x:=x+1;

Ответить

Другие вопросы из категории

помогите с вопросом:

устройство для чтения/записи данных с внешнего носителя

Читайте также

Люди,прошу вас, помогите пожалуйста, я уже долго сижу над этой задачей,не могу решить,пожалуйста помогите! =(((

найти номер третьего положительного элемента в потоке из 10 чисел или сообщить,что трех положительных элементов нет. (Решать без массива)

Помогите решить задачу.

Дан массив А1,.......Аn. найти максимальный и минимальный элементы и поменять их местами. Вот задача которую я делал:

program zadacha;
const
k=50;
var
a:array[1..k] of integer;
n,i:1..k;
c,v,max,min,prom:integer;
begin
for i:=1 to n do begin (здесь выскакивает ошибка о проверки диапазона)
a[i]:=random(50);
write(a[i],' ');
end;
max:=a[1];
min:=a[1];
for i:=1 to n do begin
if a[i]>max then begin
max:=a[i];
c:=i;
end;
if a[i]<min the begin
min:=a[i];
v:=i;
end;
end;
writeln('max=',max,'min=',min);
prom:=max; (вот с этой строчки и до конца помогите решить)
max:=min;
min:=prom;
writeln;
writeln('Полученный массив');
for i:=1 to n do
write(a[i], ' ');
readln;
end.



Вы находитесь на странице вопроса "Помогите решить!!! Уже всю голову сломал, думая над этой задачей.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.