Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

10) Ниже записана программа. Получив на вход число , эта программа печатает два числа, и . Укажите наибольшее из таких чисел , при вводе которых алгоритм

5-9 класс

печатает сначала 3, а потом 10.
var x, L, M: integer;
begin
readln(x);
L:=0; M:=0;
while x > 0 do begin
L:=L+1;
if M < x then begin
M:= (x mod 10) * 2;
end;
x:= x div 10;
end;
writeln(L); write(M);
end.
И объясните пожалуйста

крайниченко 10 дек. 2014 г., 14:30:39 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Derta
10 дек. 2014 г., 16:17:16 (9 лет назад)

вот вставь проверь там напишет при каких значениях 
var x, L, M,i,i1: integer;
begin
for i:=0 to 1000 do
begin 
i1:=i;
L:=0;
 M:=0;
while i1 > 0 do
begin
L:=L+1;
if M < i1 then
begin
M:= (i1 mod 10) * 2;
end;
i1:= i1 div 10;
end;
writeln(L);
 write(M);
end;
readln;
end.

Ответить

Читайте также

Напишите программу, которая в последовательности целых чисел находит среднее арифметическое чисел, кратных 9, или сообщает, что таких чисел нет.

Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не является членом последовательности). Количество чисел не превышает 100. Введённые числа по модулю не превышают 300. Программа должна вывести среднее арифметическое чисел, кратных 9, или вывести NO, если таких чисел в последовательности нет.

автомат получает на вход пятизначное десятичное число . по полученному числу строится новое десятичное число по следующим правилам.

1.вычислите два числа-сумма первой,третьей и пятой цифр и сумма второй и четвертой цифр заданного числа.
2.полученные два числа записываются друг за другом в порядке неубывания
пример.исходное число:15177.поразрядные суммы:9,12.результат:912
определите сколько из приведенных чисел могут получиться в результате работы автомата
50 5150 150 1520 2015 1925 1015 215 2519

в ответ запишите только количество чисел

Напишите программу, которая в последовательности натуральных чисел определяет минимальное число, делящееся нацело на 7 . Программа получает на вход

количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, делящееся нацело на 7.
Количество чисел не превышает 1000. Введеные числа не превышают 30 000.
программа должна вывести одно число - минимальное число, делящееся нацело на 7.
Завтра Гиа помогите!!!

Помогите пожалуйста Решить 2 задачи на языке Паскаль! 1) По данному числу N распечатайте все целые степени двойки, не

превосходящие N, в порядке возрастания.

Операцией возведения в степень пользоваться нельзя!

2)

В первый день спортсмен пробежал x километров, а затем он каждый день увеличивал пробег на 10% от предыдущего значения. По данному числу y определите номер дня, на который пробег спортсмена составит не менее y километров.

Программа получает на вход действительные числа x и y и должна вывести одно натуральное число.



Вы находитесь на странице вопроса "10) Ниже записана программа. Получив на вход число , эта программа печатает два числа, и . Укажите наибольшее из таких чисел , при вводе которых алгоритм", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.