Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Дано целое положительное четырехзначное число а.

5-9 класс

Найти минимальную цифру среди первых трех цифр числа, а также определить:первая или вторая цифра числа четная,или обе цифры четные,или обе цифры нечетные.Результаты вывесите на экран.

Ghblehjr 24 марта 2015 г., 18:54:47 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Buyucu2010
24 марта 2015 г., 21:15:38 (9 лет назад)

uses crt;
label goback;
var
a,b,c,d,e,f:integer;
begin
goback:
write('Введите число: ');read(a);
if (a<1000) or (a>9999) then 
  begin
    writeln('Введите четырехзначное число.');
    goto goback;
end;
b:=a div 1000;
c:=a div 100 mod 10;
d:=a div 10 mod 10;
if (b=c) and (c=d) then  begin    writeln('Первые 3 цифры равны.');  end;
if (b=c) and (c>d) then  begin    writeln(d,' - Наименьшая цифра из первых 3 цифр.');end;
if (d=b) and (b>c) then  begin    writeln(c,' - Наименьшая цифра из первых 3 цифр.');end;
if (c=d) and (d>b) then  begin    writeln(b,' - Наименьшая цифра из первых 3 цифр.');end;
if (b>c) and (c>d) and (b>d) then  begin    writeln(d,' - Наименьшая цифра из первых 3 цифр.');end;
if (c>d) and (d>b) and (c>b) then  begin    writeln(b,' - Наименьшая цифра из первых 3 цифр.');end;
if (b>d) and (d>c) and (b>c) then  begin    writeln(c,' - Наименьшая цифра из первых 3 цифр.');end;
if (b mod 2 = 0) then  begin    writeln('Первая цифра четная');  end;if (c mod 2 = 0) then  begin    writeln('Вторая цифра четная');end;
if (b mod 2 = 0) and (c mod 2 = 0) then  begin    writeln('И первая и вторая цифра четная');  end;
if (b mod 2 = 1) and (c mod 2 = 1) then  begin    writeln('И первая и вторая цифра не четная');end;
End.

Ответить

Читайте также

Дано целое положительное четырехзначное число. Напишите программу, позволяющую определить двузначное число, в котором число десятков соответствует

первой цифре заданного числа, а число единиц-последней. Например: 3234 => 34.

Помогите по программе paskal : 1.дано целое число.напишите программу которая уменьшает на 2 модуль этого числа и выводит на экран монитора

результат

2.дано целое число.напишите,программу которая выводит на экран последнюю цифру данного числа,затем возводит ее в квадрат и выводит на экран монитора результат

1.Дано целое число N.Написать программу ,увеличивающую число в 3 раза ,если оно больше нуля

2.Дано целое число N.Написать программу ,заменяющую его нулём ,если больше или равно нулю,и увеличивающая его в 2 раза ,если число меньше нуля.
3 .Дано целые числа a и b .Написать программу , которая выводит сначала большее число ,затем меньшее.
4.Даны числа a,b,c.Написать программу ,выводящую их в возрастающем порядке.
ПЛИЗ ПОМОГИТЕ

Играют двое. Первый участник игры называет произвольное целое положи­тельное число, не превышающее десяти, то есть он может назвать число десять и всякое м

еньшее десяти положительное число. Второй игрок прибавляет к на­званному числу свое целое положительное число, также не превышающее десяти, и называет сумму. К этой сумме первый прибавляет какое-либо положительное число, не превышающее десяти, и сообщает сумму. Выигрывает тот, кто пер­вый достигнет ста.
Как добиться победы?



Вы находитесь на странице вопроса "Дано целое положительное четырехзначное число а.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.