Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

составить программу выводящую на экран все делители числа x,число x,введите с клавиатуры

5-9 класс

Дагоня 25 апр. 2015 г., 19:11:37 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Otmahovazlata
25 апр. 2015 г., 20:03:22 (9 лет назад)

program m1;
uses crt;
var x,del:integer;
begin
write('Введите x: '); readln(x);
write('Делители: ');
for del:=1 to x do
if (x mod del)=0 then
write(del,' ');
writeln;
end.

Ответить

Другие вопросы из категории

Имеется условный оператор:if D<>10 then writeln (‘ура!’) else writeln (‘плохо…’);Какими операторами его можно заменить?

Выберите несколько из 4 вариантов ответа:
1) if D=10 then writeln (‘ура!’) else writeln (‘плохо…’);
2) if not (D=10) then writeln (‘ура!’) else writeln (‘плохо…’);
3) if not (D<>10) then writeln (‘ура!’) else writeln (‘плохо…’);
4) if D=10 then writeln (‘плохо…’) else writeln (‘ура!’);

помогите решить)) пожалуйста)
Компьютерные вирусы:

зарождаются
при работе неверно написанных программных продуктов;
являются
следствием ошибок в операционной системе
создаются
людьми специально для нанесения ущерба ПК
возникают
в связи сбоев в аппаратной части компьютера

Загрузочные вирусы характеризуются
тем, что:

поражают
программы в начале их работы
запускаются
при запуске компьютера
поражают
загрузочные сектора дисков
всегда
меняют начало и длину файла.






Вы хотите оформить предложение
курсивом. Для этого нужно:

поставить
курсор на начало предложения, нажать мышью кнопку Курсив
щелкнуть
мышью слева от предложения, нажать мышью кнопку Курсив
выделить
предложение и нажать сочетание клавиш Ctrl+I
выделить
предложение, используя клавишу Shift
и соответствующую стрелку, нажать мышью кнопку Курсив (Italic)

какой десятичный код буквы q

Читайте также

1.Составьте программу, выводящую на экран все двухзначные числа, у которых сумма цифр равна 8.

2.Составьте программу вычисления количества трёхзначных чисел палиндромов ( чисел, которые читаются одинаково слева направо и справа налево).
3.Найти двухзначные числа, которые делятся на сумму своих цифр
4.Составьте программу вывода количества трёхзначных чисел, у которых цифры упорядочены строго по убыванию.
РЕБЯТА СРОЧНО!!!!!!!!!!!

Даны числа a,b,c. Составить программу, выводящую на экран сообщение, в зависимости от того какой треугольник можно построить с такими длина сторон:

равносторонний,равнобедренный или какой либо другой.

Вот ещё одна

Составить программу:Даны а,b,c-целые числа.Если они большн 0-вычислите сумму их квадратов;а если хотя бы одно из них четно-вычислите их сумму и произведение.

Пожалуйста ребят.

дано натуральное число N, Написать ему выводящую на экран последовательность натуральность натуральных чисел от 1 до N, задание 2 дано натуральное число

N, Написать ему выводящую на экран последовательность натуральность натуральных чисел отN до 1, номер 3 Даны натуральные числа N и К.Написать программу выводящую на экран последовательность из N чисел , каждое из которых равно К хотя бы что нибудь решите помогите очень надо!!!!!!!!!

ПОМОГИТЕ ОЧЕНЬ НУЖНО!!!

Составьте программу, выводящую на экран все числа от -10 до 10, а также их модули



Вы находитесь на странице вопроса "составить программу выводящую на экран все делители числа x,число x,введите с клавиатуры", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.