Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Определите значение целочисленной переменной S после выполнения операторов: нц для i от 1

10-11 класс

до 3 S:=0 нц для j от 2 до 3 S:=S+i+j кц кц
ПОМОГИТЕ

Marycary19 13 нояб. 2014 г., 11:37:13 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Kiktevae
13 нояб. 2014 г., 12:35:14 (9 лет назад)

 

i = 1

   S = 0

    j = 2

      S = S + i + j = 0 + 1 + 2 = 3

    j = 3

      S = S + i + j = 3 + 1 + 3 = 7

i = 2

   S = 0

    j = 2

       S = S + i + j = 0 + 2 +2 = 4

    j = 3

       S = S + i + j = 4 + 2 + 3 = 9

i = 3

   S = 0

    j = 2

       S = S + i + j = 0 + 3 + 2 = 5

    j = 3

       S = S + i + j = 5 + 3 + 3 = 11

 

Это и есть ответ:  S = 11

  

+ 0 -
Ворона1309
13 нояб. 2014 г., 13:44:24 (9 лет назад)

береш и считаешь по шагем

i=1

s=0

j=2

s=s+i+j=0+1+2=3

j=3

s=s+i+j=3+1+3=7

i=2

s=0

j=2

s=s+i+j=0+2+2=4

j=3

s=s+i+j=4+2+3=9

i=3

s=0

j=2

s=s+i+j=0+3+2=5

j=3

s=s+i+j=5+3+3=11

 

ответ  S=11

   

Ответить

Другие вопросы из категории

Паскаль

Найти произведение двух средних цифр четырехзначного числа.

Помогите написать в паскале!

Ввести три целых числа
x, y, z. Если хотя бы одно из них четное,

то
первому четному числу присвоить значение произведения этих чисел.



Сообразил только как определить чётное или нечётное число а как дальше не могу понять!


program Lab2;
var x,y,z: integer;
Begin

Writeln ('Введите число');
Readln (x);
if x mod 2 = 0 then
writeln ('Это число чётное')
else //Иначе
writeln ('Число нечётно');

Writeln ('Введите число');
Readln (y);
if y mod 2 = 0 then
writeln ('Это число чётное')
else //Иначе
writeln ('Число нечётно');

Writeln ('Введите число');
Readln (z);
if z mod 2 = 0 then
writeln ('Это число чётное')
else //Иначе
writeln ('Число нечётно');
end.








Читайте также

Определите значение целочисленной переменной S после выполнения опеhаторов: нц для i от 1

до 2 S := 0 нц для j 2 до 3 нц для k 1 до 2 S := S+i+j+k кц кц кц
Помогите, не сходится никак с ответом

Помогите с тестами по информатике!!! А1. Определите значение целочисленных переменных a и b после выполнения фрагмента программы:

a := 3 + 3*4;

b := (a div 10) + 4;

a := (b mod 10) + 2;

b:= a + b;

a:= a mod 2 + b div 3;

1) a=4, b=14;

2) a= 24, b= 6;

3) a=5, b=12;

4) a=8, b=12.

А2. Для какого из указанных значений числа X истинно высказывание

((X < 5)→(X < 3)) Ù ((X < 2)→(X < 1))

1) 1

2) 2

3) 3

4) 4

А3. Укажите, какое логическое выражение равносильно выражению ¬(A Ú ¬B Ú C) ?

1) ¬A Ú B Ú ¬C

2) A Ù ¬B Ù C

3) ¬A Ú ¬B Ú ¬C

4) ¬A Ù B Ù ¬C

X

Y

Z

F

1

1

1

1

1

1

0

1

1

0

1

1

А4. Символом F обозначено одно из указанных ниже логических выражений от трех аргументов: X, Y, Z. Дан фрагмент таблицы истинности выражения F (см. таблицу справа).

Какое выражение соответствует F?

1) X Ú ¬Y Ú Z

2) X Ù Y Ù Z

3) X Ù Y Ù ¬Z

4) ¬X Ú Y Ú ¬Z

А5. Что будет выведено на печать в результате выполнения следующих операторов:

a := 5; b := 10;

write( 'сумма двух чисел ' ); write( 'a+b' );

write( ' = ', a+b );

1) сумма двух чисел 5+10 = 15

2) сумма двух чисел a+b = 15

3) сумма двух чисел 5+10 = a+b

4) сумма двух чисел a+b = 5+10

5) ни один из ответов 1-4 не верен

А6. Чему было равно значение переменной a, если после выполнения операций

b := sqrt( sqr(a+1) );

c := -b;

a := 1 + 2 / (c-b);

она стала равна 0 ?

1) 2

2) 0

3) –1

4) любое вещ. число, не равное -1

5) ни один из ответов 1-4 не верен

А7. Чему будет равно значение А после выполнения цикла

а:=1024;

While a>0 do

a:=a / 2;

1) 0

2) 1

3) зациклится

4) 512

5) ни один из ответов 1-4 не верен

A8. Сколько раз выполнится тело цикла?

A:=32;

While A>2 do

Begin A:=A / 2; writeln(‘A’); end;

1) 8

2) 6

3) 5

4) 4

5) 3

1)Определите значение переменной c после выполнения следующего фрагмента программы:

a :=40 ;
b := 10;
a := - a / 2*b,;
if a > b then
c := b - a
else c := a - 2 * b

2)Определите значение переменной c после выполнения следующего фрагмента программы:
a := 5;
a := a + 6;
b := - a;
c := a - 2 * b



Вы находитесь на странице вопроса "Определите значение целочисленной переменной S после выполнения операторов: нц для i от 1", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.