Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Напишите программу вычисления суммы первых чисел фибоначи, таких, что их значение s не должно превышать типа integer задача для pascal

5-9 класс

Mix97 17 марта 2015 г., 8:42:11 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Eduard82
17 марта 2015 г., 11:31:35 (9 лет назад)

Компилятора нету,попробуй этот код
var
n,sum,a,b,c,i:integer;
begin
a:=0;
b:=1;
readln(n);//Посчитать сумму первых n чисел
for i:=1 to n do
begin
sum:=sum+a;
c:=a;
a:=b;
b:=c+a;
end;
writeln(sum);
end.
--------------------------------------------------
//Через repeat until
var
n,sum,a,b,c,i:integer;
begin
a:=0;
b:=1;
i:=0;
readln(n);//Посчитать сумму первых n чисел
repeat
sum:=sum+a;
c:=a;
a:=b;
b:=c+a;
i:=i+1;
until i>=n;
writeln(sum);
end.

+ 0 -
Bakanovaу
17 марта 2015 г., 14:22:58 (9 лет назад)

МГУ соткать задачу и формулы (если надо)

Ответить

Другие вопросы из категории

решение задачи в паскале: дано предложение, все пробелы в нём заменить на *, а остальное заменить на -

Нужно менять саму строку, а не просто символы выводить

В те времена,когда дисководы были большими,а оперативная память маленькой,жила была в России мышь-манипулятор со сказочным названием.Вес этой мыши

составлял почти килограмм.Название этой мыши совпадало с именем главного регоя сказки,который любил от всех уходить.Какое количество букв в имени этого героя?Варианты ответов:А)5,Б)2,В)7,Г)4.

Помогите пожалуйста!

Читайте также

Даны три натуральных числа. Напишите программу, определяющую, существует ли треугольник с такими длинами сторон. Если существует, определите его тип

Имеются данные о количестве полных лет трех призеров спартакиады. Напишите программу, выбирающую и выводящую возраст самого младшего призера.

1)Напишите программу,которая запрашивает значения двух переменных и выводит их разность.Приглашение к вводу каждого числа произведите в отдельных

строках.Вывод результата сопроводите пояснениями
2)Напишите программу ввода трех величин( А,В,С) на одной строке,рассчитайте и выдайте на экран на отдельной строке значение выражения: (А*В)/3,14 +3С.
3)Напишите программу вычисления длины окружности и площади круга одного и того же заданного радиуса R.
Решать на паскале...Помогите пожалуйста(((



Вы находитесь на странице вопроса "Напишите программу вычисления суммы первых чисел фибоначи, таких, что их значение s не должно превышать типа integer задача для pascal", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.