Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

дано целое число N (>0). найти наименьшее целое положительное число K, квадрат которого превосходит N: K^2>N. функцию извлечения квадратного корня

10-11 класс

не использовать

Betty2000 07 нояб. 2014 г., 18:56:36 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Аlena2002
07 нояб. 2014 г., 20:27:16 (9 лет назад)

Последовательно показала ;)

+ 0 -
Alinochkakim199
07 нояб. 2014 г., 21:19:10 (9 лет назад)

var k,n:integer;
begin
readln(n);
k:=1;
while n>=k*k do
k:=k+1;
writeln(k);
end.

Ответить

Читайте также

Задачи паскаль, помогите пожалуйста кто. 1, Напишите программу, реализующую следующие вычисления. Дан номер месяца — целое число в диапазоне

1–12, введенное с клавиатуры (1 — январь, 2 — февраль и т. д.). Вывести название соответствующего времени года («зима», «весна», «лето», «осень»).

2, Напишите программу, реализующую следующие вычисления. Дана матрица размера M x N (числа вводятся с клавиатуры). Для каждого столбца матрицы найти произведение его элементов. Полученные значения вывести в текстовый файл.

3, Напишите программу с использованием функции CircleS(R) вещественного типа, находящей площадь круга радиуса R (R — вещественное). С помощью этой функции найти площади трех кругов с данными радиусами. Площадь круга радиуса R вычисляется по формуле S = πR2.

4, Напишите программу, реализующую следующие вычисления. Дано целое число N (1≤N≤26), введенное с клавиатуры. Вывести N первых прописных (то есть заглавных) букв латинского алфавита.

1)дан одномерный массив из 5 элементов.найти сумму положительных элементов. 2)Дан одномерный массив из 7

элементов.Найти колличество четных положительных элементов.

3)Дан массив из 6 элементов.Найти произвдение положительных из них.

Помогите пожалуйста решить 1) дано натуральное число. Определить номер цифры 3 в нем считая от конца числа. Если такой цифры нет то ответ

0,если их несколько то номер крайней правой.

2) Дано натуральное число. Определить сумму m его последних цифр

3)Дано натуральное число. определить его максимальную цифру.

4) дано предложение. заменить в нем все вхождения под строку str1 на подстроку str2

5) последовательность чисел Фибоначчи образуется так: первый и второй член последовательности равен 1, каждый следующий равен сумме двух предыдущих(1,1,2,3,5,,8,12..) Дано натуральное число n>=3 : а) найти k-й член последовательности б)получить первые n членов последовательности в)для заданного n определить верно ли,что сумма первых n членов есть четное число

Дана строка , в которой содержится осмысленное текстовое сообщение. Слова сообщения разделяются В заданном формате дд- целое число из диапазона от 1 до

31, мм - целое число из диапазона от 1 до 12, а гг - целое число из диапазона от 1 до 2020 (если какая-то часть формата нарушена, то данная подстрока в качестве даты не рассматривается.) Заменить каждую дату сообщения на дату следующего дня. Написать программу на Паскале. Сроооооооооооооочнооо. Пооожалуйста.....

10-11 класс информатика ответов нет


Вы находитесь на странице вопроса "дано целое число N (>0). найти наименьшее целое положительное число K, квадрат которого превосходит N: K^2>N. функцию извлечения квадратного корня", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.