Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Написать алгоритм и блок-схему для задачи:даны три действительных числа выбрать из них те, которые принадлежат интервалу (1,3)

10-11 класс

Xivice 02 янв. 2017 г., 4:43:15 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Vsahnova1
02 янв. 2017 г., 7:01:15 (7 лет назад)

const
  int = [1..3];

var
  i, j, k, n: integer;

begin
  Write('Введите через пробел три целых числа: ');
  Readln(i, j, k);
  n := 0;
  if (i in int) then begin Write(i, ' '); n := n + 1 end;
  if (j in int) then begin Write(j, ' '); n := n + 1 end;
  if (k in int) then begin Write(k); n := n + 1 end;
  case n of
    0: Writeln('Ни одно из введенных чисел не принадлежит интервалу [1..3]');
    1: Writeln(' - принадлежит интервалу [1..3]');
  else Writeln( ' - принадлежат интервалу [1..3]')
  end
end.

Тестовое решение:

Введите через пробел три целых числа: 0 0 0
Ни одно из введенных чисел не принадлежит интервалу [1..3]

Введите через пробел три целых числа: 2 5 3
2 3 - принадлежат интервалу [1..3]



Ответить

Другие вопросы из категории

Срочно ручной просчет. В Паскале.
Что из перечисленного характеризует векторную графику? 1) пикселизация при масштабировании

2) сфера применения - обработка фотографий

3) минимальный объект - графический примитив (линия, эллипс и т.д.)

4) сфера применения – полиграфия, реклама

5) изображение легко преобразуется без потери качества

6) размер файла изображения напрямую зависит от количества пикселей в изображении

(3 варианта ответа)

выполнить умножение


274,5*31,34 в восьмеричной системе счисления

Дан радиус шара. Найти его объём.

Читайте также

Циклические алгоритмы.СоставьтеЦиклические алгоритмы.Составьте блок- схему для решения следующих задач:

1) Вводятся 100 чисел.Определить сколько среди них положительных и сколько отрицательных.(Числа вводятся в одну переменную в цикле)
2) Алгоритм вычисления суммы квадратов десяти производных чисел, водимых с клавиатуры в процесс выполнения алгоритма
И НАПИШИТЕ ПРОГРАММУ ДЛЯ КАЖДОЙ ЗАДАЧИ

Помогите пожалуйста! 1)Построить развлетвляющийся алгоритм, записать алгоритмы ввиде блок-схемы и на алгоритмическом языке. Треугольник задан

длинами своих сторон – a, b, c. Определить является ли

он тупоугольным, прямоугольным или остроугольным.

2) Построить циклический алгоритм, записать ввиде блок-схемы и на алгоритмическом языке.

Построить алгоритм, который определяет количество студентов в группе,
чей рост превышает среднее для группы значение.

Дан фрагмент программы. Нарисуйте блок-схему, восстановите вид формулы для расчета S

PASCAL:

VAR
A:ARRAY[1...100]OFF
INTEGER;
N,I,J: INTEGER;
S: REAL;
BTGIN
N:=8;
FOR I:=1 TO N DO
BEGIN
S:=0;
FOR J:=1 TO I DO
S:=S+(A[J]);
S:=ABS(S);
WRITELN(`S`=`,S:9:2);
END;
READLN;
END.

QBASIC
DEFINT N,I,J,S,
DIM A(100) AS INTEGER
N:=8
FOR I=1 TO N
S=0
FOR J=1 TO I
S=S+A[J]
NEXT J
S=ABS(S)
PRINT S
NEXT I

ШКОЛЬНЫЙ АЯ

алг слово(рез вещ s)
цел раб А[1:100]
n:=8
нц для I от 1 до n
s=0
нц для j от 1 до I
s=s+a[j]
кц
s=abs(s)
вывод s
кц
кон

Пожааалуйста нужны блок-схемы для трех вариантов получения s





Нужно составить блок-схему алгоритма подготовки к сдаче к экзамену.

Я не могу сочинить этот "алгоритм", помогите ;)
Блок-схемы строить не надо, просто описать, что надо делать.



Вы находитесь на странице вопроса "Написать алгоритм и блок-схему для задачи:даны три действительных числа выбрать из них те, которые принадлежат интервалу (1,3)", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.