Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Помогите решить эти 16 вариантов, или хотя бы несколько. Что нужно сделать: Составить программу в Pascal ABC( Нужно сделать так, чтобы вы вводили

5-9 класс

координаты х и у и программа проверяет, подходит ли эта точка к графику или нет. Пример на 2 фото.
Очень нужно. 80 баллов

Lizkolove 14 апр. 2013 г., 7:35:38 (11 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Даша2116
14 апр. 2013 г., 10:20:54 (11 лет назад)

var x, y: real;
begin
     write('x = ');
     read(x);
     write('y = ');
     read(y);
     {1}
     if (y >= x + 3) and (x <= 0) and (sqr(x + 1) + sqr(y - 2) <= sqr(2)) or
        (x >= 0) and (y <= -x + 3) and (sqr(x + 1) + sqr(y - 2) <= sqr(2)) then
           writeln('1: YES')
        else
            writeln('1: NO');
     {2}
     if (y <= 2) and (y >= 0) and (sqr(x - 3) + sqr(y) >= sqr(1)) or
        (y <= 0) and (sqr(x - 3) + sqr(y) <= sqr(1)) then
           writeln('2: YES')
        else
            writeln('2: NO');
     {3}
     if (y >= 0) and (y <= x + 1) and (y <= -x + 2) or
        (y >= 0) and (y <= x - 2) then
           writeln('3: YES')
        else
            writeln('3: NO');
     {4}
     if (sqr(x - 2) + sqr(y) >= sqr(1)) and (sqr(x - 2) + sqr(y) <= sqr(2)) and
        ((x - 2) * y >= 0) then
           writeln('4: YES')
        else
            writeln('4: NO');
     {5}
     if (sqr(x) + sqr(y) <= sqr(2)) and ((y <= x - 2) or (y >= x + 2)) then
           writeln('5: YES')
        else
            writeln('5: NO');
     {6}
     if (sqr(x - 2) + sqr(y - 2) >= sqr(1)) and (y <= x + 2) and
        (y >= -x + 2) and (y >= x - 2) and (y <= -x + 6) then
           writeln('6: YES')
        else
            writeln('6: NO');
     {7}
     if (y <= 2) and (y >= -2) and (sqr(x) + sqr(y) >= sqr(1)) and
        (sqr(x - 2) + sqr(y) >= sqr(1)) and (sqr(x - 2) + sqr(y) >= sqr(1)) then
           writeln('7: YES')
        else
            writeln('7: NO');
     {8}
     if (sqr(x - 2) + sqr(y) <= sqr(2)) and (sqr(x - 2) + sqr(y) >= sqr(1)) and
        (sqr(x - 2) + sqr(y + 2) <= sqr(2)) then
           writeln('8: YES')
        else
            writeln('8: NO');
     {9}
     if (y <= 3) and (y >= 0) and (y >= x) and (y >= -x + 3) or
        (y <= 3) and (y >= 0) and (y <= x) and (y <= -x + 3) then
           writeln('9: YES')
        else
            writeln('9: NO');
     {10}
     if ((sqr(x - 3) + sqr(y) <= sqr(2)) and (sqr(x - 3) + sqr(y) >= sqr(1)) or
        (sqr(x - 3) + sqr(y) <= sqr(4)) and (sqr(x - 3) + sqr(y) >= sqr(3))) and
        (y >= 0) then
           writeln('10: YES')
        else
            writeln('10: NO');
     {11}
     if (y <= 2) and (y >= -2) and (x >= -2) and (x <= 2) and
        (sqr(x - 2) + sqr(y - 2) >= sqr(1)) then
           writeln('11: YES')
        else
            writeln('11: NO');
     {12}
     if (y <= 3) and (y >= 1) and (x >= 1) and (x <= 5) and
        (sqr(x - 3) + sqr(y - 2) >= sqr(1)) then
           writeln('12: YES')
        else
            writeln('12: NO');
     {13}
     if (y <= 0) and (y >= -3) and (x >= -1) and (x <= 1) or
        (y <= x + 2) and (y <= -x + 2) and (y >= 0) then
           writeln('13: YES')
        else
            writeln('13: NO');
end.

Последние 3, я думаю, можно оставить Вам)

Ответить

Другие вопросы из категории

Задали такую задачку....не могу понять как её решать

N1=16
N2=64
К1=200
К2=100
нужно найти:
I1=?
II2=?

Программа выполняется в паскале! Составьте программу для решения следующей задачи:Процентная ставка по вкладу – 15% годовых.

Первоначальный вклад составил А рублей. Через сколько лет он станет больше В рублей? Значения А и В вводятся с клавиатуры. Помогите плииз.

74 в байтах.........?

70966 в байтах,,,,,,,,,,?
70966 в кигабайтах...........?
70966 в мегабайтах.....?

Самолёт находится на высоте 5000 метров. Обнаружилась неисправность работы двигателя. Самолёт начал падать. Бортовой компьютер производит диагностику неисп

равности и сообщает пилоту о необходимых действиях. Для решения этой задачи ему нужно выполнить 108 вычислительных операций. Быстродействие компьютера – 1 млн. операций в секунду. Успеет ли лётчик спасти самолёт, если минимальная высота, на которой самолёт можно вывести из пике – 2000 метров?

Читайте также

программирование в Сишке. Дана программа: #include < stdio.h> int main(void) { int A,B,C; printf(

"Введите два числа\n");

scanf( "%d %d",&A,&B);

С=A+B;

printf( " Ответ: %d" , C);

return 0;

}

теперь вопрос, как можно ее исправить или что нужно сделать с программой что бы последнее действие ( return 0;) не нужно было писать и выполнять?

Люди Люди Люди если вы читаете это сообщение значит вы просто обязаны помочь! пожалуйста если у вас есть паскаль помогите пожалуйста решить первое и

второе задание ну или хотя бы только первое .Это вопрос жизни и смерти помогите пожалуйста P.S задание во вложениях.заранее спасибо и знайте если вы поможете значит вы самый добрый и отзывчивый человечек!)



Вы находитесь на странице вопроса "Помогите решить эти 16 вариантов, или хотя бы несколько. Что нужно сделать: Составить программу в Pascal ABC( Нужно сделать так, чтобы вы вводили", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.