Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

1)Составьте программу,которая заполняет массив e[1..11] случайными целыми числами в диапазоне от -15 до 1 и находит количество элементов кратных 5.

5-9 класс

2)Составьте программу,которая заполняет массив e[1..8] случайными целыми числами в диапазоне от 1 до 20 и находит сумму элементов с нечётными значениями и количество элементов кратных 3.
3)Составьте программу,которая заполняет массив e[1..14] случайными целыми числами в диапазоне от -10 до 10,затем изменяет знак положительных элементов на противоположный,а отрицательные элементы заменяет на 0.Спасибо.

Ykaa 07 окт. 2014 г., 1:24:50 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Naumova2
07 окт. 2014 г., 1:59:23 (9 лет назад)

1)
var e:array[1..11]of integer;
     i,k:integer;
begin
 for i:=1 to 11 do
  begin
   e[i]:=random(17)-15;
   write(e[i],' ');
   if e[i] mod 5=0 then k:=k+1;
  end;
 writeln;
 write('kol-vo elem krat 5:',k);
end.
2)
var e:array[1..8]of integer;
     i,s,k:integer;
begin
 for i:=1 to 8 do
  begin
   e[i]:=random(20)+1;
   write(e[i],' ');
   if e[i] mod 2=1 then s:=s+e[i];
   if e[i] mod 3=0 then k:=k+1;
  end;
 writeln;
 writeln('summa nechet elem:',s,' kol-vo elem krat trem:',k);
end.
3)
var e:array[1..14]of integer;
     i:integer;
begin
 write('nachalni massiv:');
 for i:=1 to 14 do 
  begin
   e[i]:=random(21)-10;
   write(e[i],' ');
  end;
 writeln;
 write('izmeneni massiv:');
 for i:=1 to 14 do
  begin
   if e[i]<0 then e[i]:=0
               else e[i]:=e[i]*(-1);
  write(e[i],' ');
 end;
end.

Ответить

Другие вопросы из категории

Помогите сделать задачу в Excel по теме работа с различными функциями От железнодорожной станции по направлению к дачному

поселку (расстояние между ними 2000) движется пешеход со скоростью 5 км/ч. Одновременно с ним в
том же направлении бежит собака, со скоростью 10 км/ч. Поскольку собака
бежит быстрее, то, добежав до дома и
радостно известив о приближении хозяина, она разворачивается и бежит к
человеку, а от него обратно к дому т.д. Какой суммарный путь пробежит собака за
время, пока человек дойдет до дома?

уточните каков обьём жёсткого диска компьютера к которому вы имеете доступ дома или в школе сколько страниц текста можно было бы разместить в памяти

этого компьютера на странице размещается 40 строк по 60символов в каждой строке какой была бы высота такой стопки страниц если высота стопки из 100 страниц равна 1см

Читайте также

1)составьте программу,которая заполняет массив a[1..10] случаынми целыми числами в диапазоне от 0 до 10 и находит минимальный элемент массива среди

элементов с нечётными индексами

2)составьте программу,которая заполняет массив a[1..10]случайными целыми числами в диапазоне от 0 до 10,находит максимальный элемент массива,а затем вычисляет,сколько раз он встречается в массиве

№1 Составьте программу, которая заполняет массив a[1..10] случайными целыми числами в диапазоне от 1 до 10 и вычисляет произведение массива с четными

значениями. №2 Составьте программу, которая заполняет массив a[1..10] случайными целыми числами в диапазоне от 1 до 10 до 10 и вычисляет среднее арифметическое элементов массива. №3 Такое же как и №2, только ...элементов массива с четными значениями.

A) Составьте программу, которая заполняет массив a[1..10] случайными целыми числами в диапазоне от 1 до 10 и находит сумму элементов с четными значениями

и количество элементов с нечетными значениями.

б) Составьте программу, которая заполняет массив b[1..8] случайными целыми числами в диапазоне от 1 до 10 и находит произведение элементов с нечетными значениями и количество элементов с четными значениями.

4 а) составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 , затем элементы с четными индексами

удваиваются , а элементы с нечетными индексами утраивает.Выведите на экран исходный и полученный массив.

б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 , затем изменяет знак элементов с четными индексами на противоположный .Выведите на экран исходный и полученный массивы.

5) а)составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит количество элементов ,которые больше своего соседа слева

б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 и находит количество пар элементов с четными значениями.

6) а)составьте программу ,которая заполняет массив а[1..20 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит среднее арифметическое элементов с четными значениями и нечетными индексами.

б) составьте программу ,которая заполняет массив b[1..15 ] случайными целыми числами в диапозоне от 1 до 20 и выводит все тройки элементов , упорядоченные строго по возрастанию.

4 а) составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 , затем элементы с четными индексами

удваиваются , а элементы с нечетными индексами утраивает.Выведите на экран исходный и полученный массив.
б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 , затем изменяет знак элементов с четными индексами на противоположный .Выведите на экран исходный и полученный массивы.
5) а)составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит количество элементов ,которые больше своего соседа слева
б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 и находит количество пар элементов с четными значениями.
6) а)составьте программу ,которая заполняет массив а[1..20 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит среднее арифметическое элементов с четными значениями и нечетными индексами.
б) составьте программу ,которая заполняет массив b[1..15 ] случайными целыми числами в диапозоне от 1 до 20 и выводит все тройки элементов , упорядоченные строго по возрастанию.
напишите хоть какое нибудь нужно к завтрому срочно



Вы находитесь на странице вопроса "1)Составьте программу,которая заполняет массив e[1..11] случайными целыми числами в диапазоне от -15 до 1 и находит количество элементов кратных 5.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.