Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

С клавиатуры водиться последовательность из n- целых чисел. Сколько в ней четных чисел?(нужно: 1) постановка задачи; 2) алгоритм и 3)

5-9 класс

программа)

Alosha3253 04 февр. 2015 г., 2:03:52 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Ardana
04 февр. 2015 г., 4:52:33 (9 лет назад)

program picaso; uses crt;
var i,n,k:integer;
a:array[1..10] of integer;
begin clrscr;
 k:=0;
 writeln('Vedite nomer cisel');read(n);
 for i:=1 to n do
 begin
 write('A[',i,']=');
 readln(a[i]);
 end;
 for i:=1 to n do if (a[i] mod 2)=0 then inc(k);
 writeln('Nomer ciotnih cisel: ',k);
end.

Ответить

Другие вопросы из категории

1)напишите программу которая спрашивала бы название продукта и его цену. И затем на экран выводила фразу "Ваши расходы на покупки равны руб." 2) написать

программу, которая запрашивала три числа, подсчитывала их средне и сумму и на экран выводила фразу "Их среднее равно..." и "Их сумма равна..."

Читайте также

1)Задан массив из 11 целых чисел. Найти сумму элементов массива, кратных 5 2)Задан массив из 11 целых чисел. Посчитать количество нечётных

элементов массива.

3)задан массив из 9 целых чисел.Вывести на экран чётные элементы

Помогите Решить 4 любые задачи:

1)С клавиатуры вводится последовательность чисел, оканчивающаяся 0. Сколько элементов последовательности превышает число 100?
2)Вводится последовательность из 10 вещественных чисел. Вычислить сумму элементов, не превышающих числа А.
3)С клавиатуры вводится последовательность из 7 целых чисел. Определить каких чисел больше: четных или нечетных.
4)С клавиатуры вводится последовательность из 9 чисел. Найти разность между макимальным и минимальным элементами.
5)С клавиатуры вводится последовательность чисел, оканчивающаяся 0. Найти порядковый номер отрицательного элемента, если считать элементы справа. В случае нескольких отрицательных элементов вывести номер последнего из них (т.е. самого правого).
6)С клавиатуры вводится последовательность чисел, оканчивающаяся 0. Найти порядковый номер первого двузначного элемента последовательности, считая элементы в прямом порядке.
7)С клавиатуры вводится последовательность положительных чисел, оканчивающаяся 0. Найти сумму двузначных элементов последовательности.
8)С клавиатуры вводится последовательность чисел, оканчивающаяся 0. Найти произведение отрицательных элементов последовательности.
9)С клавиатуры вводится последовательность чисел, оканчивающаяся 0. Найти в ней минимальный элемент.
10)С клавиатуры вводятся числа 2, 5 или 10, означающие удаления игроков на соответствующее кол-во минут. Условно положительные значения означают удаления в команде А, а отрицательные - в команде В. Для завершения ввода данных используется 0. Сколько всего штрафного времени заработано командами А и В отдельно, а также определить общее штрафное время.



Вы находитесь на странице вопроса "С клавиатуры водиться последовательность из n- целых чисел. Сколько в ней четных чисел?(нужно: 1) постановка задачи; 2) алгоритм и 3)", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.