Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Создайте массив и подсчитайте сумму и среднее арифметическое элементов массива.

5-9 класс

Naimakarakaeva 26 янв. 2017 г., 13:59:43 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Lizazotova2002
26 янв. 2017 г., 15:19:22 (7 лет назад)

На каком языке нужно?...

Вот на perl пример:
#!/usr/bin/perl
@arr=(1,2,3,4,5,6,7,8,9);
foreach(@arr){$sum+=$_};
$avr=$sum/scalar(@arr);
print "$sum\n";
print "$avr\n";

На pascal:
program test;
var
 arr:array[1..10] of integer;
 i,sum:integer;
 avg:real;
begin
for i:=1 to 10 do
begin
 arr[i]:=random(100);
 writeln(arr[i]);
 sum:=sum+arr[i];
end;
avg:=sum/10;

writeln;
writeln(sum);
writeln(avg);
readln;
end

Ответить

Другие вопросы из категории

ПОЖАЛУЙСТА, КТО-НИБУДЬ, НАПИШИТЕ, НА ЗАВТРО НАДО, СРОЧНО, ПЛИИЗ!!! лЮДИ, УМОЛЯЮ! И ВСЁ ПО ПАРЯДКУ ПИСАТЬ, КУДА ЗАХОДИШЬ, КАК ,ЧТО ДЕЛАЕШЬ!

1.Откройте в Программе просмотра изображений и факсов любой графический файл в формате ВМР ( например, Тема 7\ Задания 7.1\ образец bmp.). Сохраните этот рисунок в форматах JPG, GIF, TIFF. Сравните размеры созданных файлов с оригиналом. Объясните, как влияет формат файла на его размер и качество изображения. 2. Просотрие значение свойств файлов графических изобраений( например, из папки Тема 7\ задания 7.1\ Упражнение 7) Спомощью команды свойства контекстного меню этих объектов и заполните таблицу. Сделайте вывод, как зависит размер файла от вида графики. Там 1-векторная и 1 -растровая

Читайте также

1.Дан массив целых чисел, найти среднее арифметическое всех элементов массива.

2. Дан массив целых чисел,найти количество отрицательных элементов массива.
3. Дан массив целых чисел,найти количество чётных чисел в массиве.

1. Дан массив А из 10 элементов, которые заполняются случайным образом, числам от 0 100. Выведите массив на экран и найдите максимальный элемент массива.

2. Создать массив A из 10 элементов, заполненный случайным образом числами принадлежащих промежутку (0;20). Вывести полученный массив на экран. Вычислить количество элементов массива, значения которых не превышают среднее арифметическое значений его элементов.

№1 Составьте программу, которая заполняет массив a[1..10] случайными целыми числами в диапазоне от 1 до 10 и вычисляет произведение массива с четными

значениями. №2 Составьте программу, которая заполняет массив a[1..10] случайными целыми числами в диапазоне от 1 до 10 до 10 и вычисляет среднее арифметическое элементов массива. №3 Такое же как и №2, только ...элементов массива с четными значениями.



Вы находитесь на странице вопроса "Создайте массив и подсчитайте сумму и среднее арифметическое элементов массива.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.