Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

Паскаль:Массив состоит из 20 элементов.Найти сумму нечётных элементов.Найти сумму чётных элементов.Надо сделать с использованием Random.Помогите

5-9 класс

плиз!!!

Bahmantema 18 дек. 2016 г., 21:04:02 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Ludaaa96
18 дек. 2016 г., 22:24:20 (7 лет назад)

const n=20;
var
a:array [1..n] of integer;
i,s,k:integer;
begin
s:=0;
k:=0;
Randomize;
for i:=1 to n do
begin
  a[i]:=random(50);
  write(a[i],' ');
end;
for i:=1 to n do if (a[i] mod 2 =0) then s:=s+a[i]
                                     else k:=k+a[i];
writeln;
writeln('Сумма четных элементов: ',s);
writeln('Сумма нечетных элементов: ',k);
end.

Ответить

Другие вопросы из категории

Установите соответствия

Библиотека , болото, самолёт, вулкан, оркестр, степь
Смешанная система :
Природная система :
Техническая система :

Читайте также

ССССРРРРРРРРРРРРРРЛОООООООООООЧЧЧЧЧЧЧЧНООООООООО!!! 1. Заполнить одномерный массив, состоящий из 10 элементов, случайными числами от-15 до 35.

Найти сумму элементов данного массива.
2. Заполнить одномерный массив, состоящий из 10 элементов, случайными числами от-15 до 35.
Найти значение максимального элемента массива.

1. Дан массив А из 10 элементов, которые заполняются случайным образом, числам от 0 100. Выведите массив на экран и найдите максимальный элемент массива.

2. Создать массив A из 10 элементов, заполненный случайным образом числами принадлежащих промежутку (0;20). Вывести полученный массив на экран. Вычислить количество элементов массива, значения которых не превышают среднее арифметическое значений его элементов.



Вы находитесь на странице вопроса "Паскаль:Массив состоит из 20 элементов.Найти сумму нечётных элементов.Найти сумму чётных элементов.Надо сделать с использованием Random.Помогите", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.