Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Дано трёхзначное число проверить,будет ли сумма его цифр чётным или не чётным числом.

10-11 класс

XDDDDDDDDD 21 июля 2014 г., 11:58:55 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Стєрвочка
21 июля 2014 г., 13:48:23 (9 лет назад)

Что бы узнать число чётное или нет нужно посмотреть на что он кончается если число кончается на 2;4;6;8;0 то чётное если на все остальные цифры то не чётное

Ответить

Другие вопросы из категории

ПАСКАЛЬ АБС! СРОЧНО! ПОМОГИТЕ ПОЖАЛУЙСТА!

1. напишите программу формирования массива размером 5*5 с помощью датчика случайных чисел. Замените в нем нечетные значения элементов максимальным. Выведите на экран исходный и измененный массивы.
2. Составьте программу формирования и вывода на печать одномерного массива, состоящего из максимальных элементов строк двумерного массива, заданного с помомщью датчика случайных чисел

Перевести числа из одной системы счисления в другую:

123 (5) в ( ) (10)
1023 (4) в ( ) (10)
0,4412(5) в ( ) (10)
0,076 (8) в ( ) (10)
123(10) в ( ) (5)
149 (10) в ( ) (8)
1500 (10) в ( ) (8)
25 (10) в ( ) (2)

Проверьте пожалуйста программу.

program f_3;
var f1, f2, f3:text;
C:integer;
G:char;
s:string;
sp:string;
begin
s:=('');
sp:=(' ');
Assign(f1, 't.txt');
Assign(f2, 't2.txt');
Assign(f3, 't3.txt');
Reset(f1);
Rewrite(f2);
Rewrite(f3);
while not eof(f1) do
begin
readln(f1,G);
C:=ord(G);
writeln(f2,inttostr(C));
end;
Reset(f2);
while not eof(f2) do
begin
readln(f2,C);
G:=chr(C);
writeln(f3,G);
end;
close(f1);
close(f2);
close(f3);
end.


Читайте также

1.Дано двузначное число.Определить: a.какая из его цифр больше,первая или вторая; b. одинаковы ли его цифры. 2. Дано двухзначное число.

Определить,равен ли квадрат этого числа учетверённой сумме кубов его цифр. Например, для числа 48 ответ положительный, для числа 52-отрицательный. 3. Дано двузначное число. Определить: a. кратна ли трём сумма его цифр b. кратна ли сумма его цифр числу a. 4. Дано трёхзначное число Определить,равен ли квадрат этого числа сумме кубов его цифр. 5. Дано двузначное число,определить:входит ли в него цифра 3: входит ли в него цифра a.

Помогите написать программу на C++

Дано трехзначное число N. Проверить, будет ли сумма его цифр четным числом.
Я новичок в этом, так-что желательно с пояснениями.
( В интернете есть решение данной задачи, но там очень всё запутанно для начинающего, а если нам это задали, уверенна есть вариант намного проще)

5. Дано трехзначное число. Кратна ли сумма его цифр семи?

8. Дано три натуральных числа x, y, z. Вычислить количество чисел меньших 50.

Дано натуральное число: определить а) количество цифр в нем б)сумму его цифр в)произведение его цифр г)среднее арифметическое его цифр

д)сумму квадратов его цифр е)сумму кубов его цифр ж)его первую цифру з)сумму его первой и последней цифр



Вы находитесь на странице вопроса "Дано трёхзначное число проверить,будет ли сумма его цифр чётным или не чётным числом.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.