Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

на паскаль ABC

10-11 класс

1).составте программу которая удаляет первое слово текста
2)составте программу которая вставляет одно слово в текст после первого пробела

Mirzahmedova14 15 дек. 2014 г., 6:42:05 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Mari577
15 дек. 2014 г., 7:28:57 (9 лет назад)

1) var
s, s1:string;
c:char;
begin
repeat begin read (c); s1:=s1+c; end until c=' ';
read (s);
write (s);
end.
2)var
s, s1, s2:string;
c:char;
begin
read (s);
while (c<>' ') do begin read (c); s1:=s1+c; end;
read (s2);
write (s1, ' ', s, ' ', s2); end.
где первым вводится слово, которое нужно вставить



Ответить

Другие вопросы из категории

Задание

Определить без компьютера, что будет напечатано при выполнении следующих фрагментов программ:
1. k:=20; k:=k+10; if k+10<>30 then k:=8 else k:=k-1; WriteLn (k)
Ответ:
2. k:=20; k:=k+10; if k+10 = 30 then k:=8 else k:=k-1; WriteLn (k)
Ответ:
3. p:=1; if p>0 then p:=p+5; Write (p); if p>10 then p:=p+1; Write (p)
Ответ:
4. p:=5; if p>0 then p:=p*2 else p:=12; if p>5 then p:=p-1 else p:=p+1; WriteLn(p);
Ответ:
5. p:=0;p:=p+1; if p=0 then p:=5 else p:=p-1; WriteLn(p);
Ответ:
6*. p:=5;p:=p*2; if p mod 2=0 then WriteLn(p) else WriteLn(0);
Ответ:

что дарят в Голандии
В комнате

веселились 1426 мух. Петр Петрович открыл форточку и, размахивая
полотенцем, выгнал из комнаты 226 мух. Но, прежде чем он успел
закрыть форточку, 214 мух вернулись обратно. Сколько мух теперь
веселится в комнате?

Дешифруйте следующие двоичные числа, преобразовав их в десятичные: 0010, 1011, 11101, 0111, 0101.Дешифруйте следующие восьмеричные числа, преобразовав их

в десятичные: 777, 375, 111, 1015.Дешифруйте следующие шестнадцатеричные числа, преобразовав их в десятичные: 15, A6, 1F5, 63.

Читайте также

Разработать программу с использование

графического режима на паскале abc

.
Реализовать программу, которая
периодически выводит на экран «звездное
небо» и затем гасит его.

Вводится последовательность целых чисел, по абсолютной величине меньших или равны 100. Найти и вывести на печать количество отрицательных чисел и сумму

всех чисел, расположенных после первого нулевого элемента.
Написать на Паскале буду очень благодарен!!

Написать программу на паскале: Дана матрица А, имеющая N строк и N столбцов.

Сформируйте два одномерных массива. В один перешлите четные, а в другой
-нечетные элементы матрицы. Выведите на экран все массивы.



Вы находитесь на странице вопроса "на паскаль ABC", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.