Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Програмку написать нужно... Вывести все двузначные числа,сумма цифр которых равна n или в которых есть цифра n .

5-9 класс

Fyz123Yo 14 июля 2013 г., 6:22:51 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Vadim10030
14 июля 2013 г., 7:30:55 (10 лет назад)

Держи! Код на прикрепленном изображении. 

+ 0 -
Mama78sofia
14 июля 2013 г., 9:33:09 (10 лет назад)

Любое двухзначное число записывается в виде 10*a+b, где а - число десятков (старшая цифра), b - число единиц (младшая цифра).
Тогда условие будет иметь вид: (a+b=n) или (a=n) или (b=n), где а меняется от 1 до 9, b меняется от 0 до 9.

var
  n, a, b: integer;

begin
  Write('Введите число n -> '); Readln(n);
  for a := 1 to 9 do
    for b := 0 to 9 do
      if (a + b = n) or (a = n) or (b = n) then Write(a, b, ' ');
  Writeln
end.

Тестовое решение:
Введите число n -> 7
16 17 25 27 34 37 43 47 52 57 61 67 70 71 72 73 74 75 76 77 78 79 87 97

Ответить

Другие вопросы из категории

№1

Выберите определение компьютерного вируса.
1)прикладная программа
2)системная программа
3)программа, выполняющая на компьютере несанкционированные действия
4)база данных
№2
как размножается программный вирус?
1)программа-вирус 1 раз копируется в теле другой программы
2) вирусный код неоднократно копируется в теле другой программы
3)программа-вирус прикрепляется у другой программе
4)вирусный код 1 раз копируется в теле другой программы
№3
выберите методы реализации антивирусной защиты
1)аппаратные и программные
2)программные,аппаратные и организационные
3)только программные
4)достаточно резервного копирования данных
№4
как работает антивирусная программа?
1)на ожидании начала вирусной атаки
2)на сравнении программных кодов с известными вирусами
3)на удалении зараженных файлов
4)на блокировании неизвестных файлов
№5
Назовите вспомогательные средства защиты от вирусов
№6
как называется специально написанная программа, которая может "приписывать" себя к другим программам для выполнения каких-либо вредных действий?
№7
назовите самый надежный тип антивирусных программ

В следующих примерах укажите информационный носитель и форму представления информации:

а) табличка с номером дома
б) почтовая открытка
в) билет на поезд
г) газета
д) диск со сборником мультфильмов

Напишите программу, которая в последовательность натуральных чисел определит значение наибольшего из всех нечетных введеный чисел. Программа

получает на вход целые числа, количество введеных чисел неизвестно, последовательность чисел заканчивается числом 0 (0 - признак окончания ввода, не входят в последовательность) .

Количество чисел не привышает 1000. Введеные числа не привышают 30000.

Программа должна вывести одно число - наибольшее из всех нечеиных введеных чисел.

Пример работы программы:

Входные данные Выходные данные

15 17

20

17

0

Читайте также

Нужна помощь в составлении алгоритма (паскаль АВС) -8 класс.

1 задание: Составьте программу вычисления количества двухзначных чисел,которые кратны 2 и 3.
2 задание: Составьте программу,выводящую на экран все двузначные числа,у которых первая цифра в два раза больше второй.
3 задание: Найдите количество двузначных чисел,которые делятся на сумму своих цифр.
P.S. Помогите пожалуйста! Очень нужно и срочно! Если можете,то нужно всё сделать; если же нет,то хотя-бы одну или две задачи. Заранее спасибо!!!)))

1. Производительность формовочной машины - 7 тарелок в минуту. Сколько тарелок произведут N машин за T часов?

2. Составить программу удвоения большего из двух чисел.

3. Написать программу вычисления произведения всех двузначных четных чисел.

4. Определить количество двузначных натуральных чисел, сумма цифр которых равна заданному числу N.

Все в Pascal. Очень прошу помочь



Вы находитесь на странице вопроса "Програмку написать нужно... Вывести все двузначные числа,сумма цифр которых равна n или в которых есть цифра n .", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.