Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Паскаль

1-4 класс

1)Ввести четырехзначное целое число. Вычислить произведение чисел, состоящих во втором и третьем разрядах.

2(Ввести дробное число. Вычислить произведение целой и дробной части числа.

Яна1234556 12 июня 2014 г., 8:35:43 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
11121975
12 июня 2014 г., 10:07:02 (9 лет назад)

1)uses crt;
var a,b,p:integer;
begin
readln(a);
a:=a div 10;
a:=a mod 100;
b:=a mod 10;
a:=a div 10;
p:=a*b;
writeln(p);
end.

2)uses crt;
var  a,i,n,b,p:integer;
s,s1:string;
begin
s1:='';
readln(s);
n:=pos('.',s)-1;
for i:=1 to n do
s1:=s1+s[i];
a:=StrToInt(s1);
n:=length(s)-n+1;
s1:='';
for i:=n to length(s) do
s1:=s1+s[i];
b:=StrToInt(s1);
p:=a*b;
writeln(p);
end.









Ответить

Читайте также

Даны числа: x, y. Вычислите: z=x+y, если

x \leq y, и z=x-y в противном случае.

Написать программу в паскале.

Коллеги помогите !!!!!!!!!!

Впиши в таблицу имена и свойства объектов. Учёный Паскаль Талантливый.

---------- Шишкин ----------------
Композитор ---------- -----------
Озеро ----------- ----------------
------------ Лондон ---------------
----------- ------------ --------------

8 класс Паскаль номер 5 а) б)


Вы находитесь на странице вопроса "Паскаль", категории "информатика". Данный вопрос относится к разделу "1-4" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.