Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

помогите решить задачу -Пяти гномам показали 3 красных и 4 синих капюшона .Затем в темноте на них надели 3 красных и 2 синих капюшона,а остальные капюшоны

10-11 класс

спрятали.Кто из гномов может определить цвет надетого на него капюшона?

Lyubov95 07 янв. 2015 г., 22:39:17 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
JuliaLiving
08 янв. 2015 г., 0:14:37 (9 лет назад)

цвет капюшона могут определить те два гнома, что в синем. потому что им известно, что всего красных капюшона 3. и перед собой они видят трех гномов в красных капюшонах->на них самих не красные капюшоны->синие.

Ответить

Другие вопросы из категории

12. Какие из приведенных ниже моделей являются статическими? Выбрать три правильных ответа.

А) карта местности;
Б) дружеский шарж;
В) программа, имитирующая движение стрелок циферблата на экране дисплея;
Г) план сочинения;
Д) график изменения температуры воздуха в течение дня.
13. Какие из утверждений являются верными? Выбрать два правильных ответа.
А) математическая формула является информационной моделью;
Б) график движения поезда - табличная статическая модель;
В) план дома - графическая детерминированная модель, описывающая структуру объекта;
Г) турнирная таблица чемпионата по футболу - эталонная динамическая модель.

Помогите составить блок-схему к программе:

var x,y:real;
Begin
write('Введите х: ');
readln(x);
if (x>100) and (x<>105) then y:=sqrt(x)
else if (x=20) or (x=40) then y:=power(x,1/3)
else y:=sqr(x)+1;writeln('y=',y)
End.

Читайте также

Помогите решить задачу.

Дан массив А1,.......Аn. найти максимальный и минимальный элементы и поменять их местами. Вот задача которую я делал:

program zadacha;
const
k=50;
var
a:array[1..k] of integer;
n,i:1..k;
c,v,max,min,prom:integer;
begin
for i:=1 to n do begin (здесь выскакивает ошибка о проверки диапазона)
a[i]:=random(50);
write(a[i],' ');
end;
max:=a[1];
min:=a[1];
for i:=1 to n do begin
if a[i]>max then begin
max:=a[i];
c:=i;
end;
if a[i]<min the begin
min:=a[i];
v:=i;
end;
end;
writeln('max=',max,'min=',min);
prom:=max; (вот с этой строчки и до конца помогите решить)
max:=min;
min:=prom;
writeln;
writeln('Полученный массив');
for i:=1 to n do
write(a[i], ' ');
readln;
end.

Помогите, пожалуйста, решить задачи.

1. В один из жарких летних дней Петя и его друг Вася решили купить арбуз. Они выбрали самый большой и самый спелый, на их взгляд. После недолгой процедуры взвешивания весы показали w килограмм. Поспешно прибежав домой, изнемогая от жажды, ребята начали делить приобретенную ягоду, однако перед ними встала нелегкая задача. Петя и Вася являются большими поклонниками четных чисел, поэтому хотят поделить арбуз так, чтобы доля каждого весила именно четное число килограмм, при этом не обязательно, чтобы доли были равными по величине. Ребята очень сильно устали и хотят скорее приступить к трапезе, поэтому Вы должны подсказать им, удастся ли поделить арбуз, учитывая их пожелание. Разумеется, каждому должен достаться кусок положительного веса.
Входные данные
В первой и единственной строке входных данных записано целое число w (1 ≤ w ≤ 100) — вес купленного ребятами арбуза.
Выходные данные
Выведите YES, если ребята смогут поделить арбуз на две части, каждая из которых весит четное число килограмм, и NO в противном случае.
Примечание
Например, ребята могут поделить арбуз на две части размерами 2 и 6 килограммов соответственно (другой вариант — две части 4 и 4 килограмма).

2. На клетчатой плоскости заданы координаты K зданий. Требуется построить кольцевую дорогу вокруг зданий минимальной длины в виде прямоугольника, со сторонами, параллельными линиям сетки.
Входные данные
Во входном файле, на первой строке, находится число K( ). На следующих K строках находятся пары чисел и – координаты зданий
( ).
Выходные данные
Выведите в выходной файл координаты левого нижнего и правого верхнего углов прямоугольника.

3. Хакер Иван является сотрудником крупной антивирусной компании. Один из вирусов исследованием, которого он занимается, был специально создан для атаки на программы биржевой торговли.
Для того что бы победить зловред Ване необходимо разработать алгоритм, который бы вычислил минимальное количество операций необходимых для того что бы пара чисел (a, b) стала "k -красивой". Пара чисел (a, b) называется "k-красивой" если хотя бы одно из чисел парны не меньше заданного целого числа k. При этом, операции, проводимые с парой чисел (a, b) могут быть только такие:
1. Пара (a, b) может быть преобразована в (a+b, b);
2. Пара (a, b) может быть преобразована в (a, b+a).
Помогите Ване победить.
Входные данные
Единственная строка входных данных содержит три целых числа a, b и k ( - 1018 ≤ x, y, m ≤ 1018).
Выходные данные
Выведите минимальное количество операций или число -1, если сделать заданную пару "k-красивой" невозможно.

4. Инженер-программист Надежда занимается разработкой компилятора для нового сверх секретного языка программирования. Для того чтобы закончить разработку одного из модулей ей остается решить задачу следующего содержания:
Во входных данных Надя получает строку содержащую в себе цифры и скобки одного вида: '(' и ')'. Наде необходимо написать программу, которая для любых входных данных определяет является ли содержащаяся в них скобочная последовательность правильной, и в случае правильности скобочной последовательности возвращает количество встречающихся в ней скобок, если же последовательность неправильная, то выводится число -1.
Скобочная последовательность называется правильной, если:
1. Пустая строка — правильная скобочная последовательность;
2. Правильная скобочная последовательность, взятая в скобки одного типа — правильная скобочная последовательность;
3. Правильная скобочная последовательность, к которой приписана слева или справа правильная скобочная последовательность — тоже правильная скобочная последовательность.
Помогите Наде в разработке компилятора для нового сверх секретного языка программирования.
Входные данные
Единственная строка конечной длины содержит цифры и скобки, длина строки не больше 1024 символов.
Выходные данные
Выведите количество скобок если скобочная последовательность правильная или число -1 если нет.

5. Маленький Вася научился считать сумму цифр для любого числа. Для любого числа, он считал сумму его цифр, затем тоже самое он делал с полученным в результате числом и так далее. Определите сколько раз Васе необходимо посчитать сумму, чтобы она стала цифрой.
Входные данные
Одна непустая строка с числом (0 Выходные данные
Одна строка, с числом.

Срочно!!!!!!!!!!!!!!!!!!!!!!!!! Помогите, пожалуйста, решить задачу по теории вероятности 11 класс.

В ящике лежат 3 белых, 6 красных и 1 синий шар. Наугад вынимают один шарик. Какова вероятность того, что он: а) не белый; б) что он красный?

помогите решить задачу

Задача 3. Веселые человечки. Горючее
Как известно, автомобиль, изобретенный Винтиком и Шпунтиком, работает не на бензине, а на газировке разных сортов. Готовясь к путешествию, Незнайка закупил 10 литров кока-колы, 5 литров лимонада и 10 литров фанты. Винтик и Шпунтик вместе купили 10 литров лимонада и 10 литров фанты. Торопыжка – 5 литров фанты, 10 – кока-колы и 10 – лимонада. Поэт Цветик – 20 литров фанты.
Сколько всего литров горючего купил каждый из человечков, сколько это стоило и какое расстояние можно проехать на этом горючем; сколько всего горючего всех видов было куплено всеми человечками?



Вы находитесь на странице вопроса "помогите решить задачу -Пяти гномам показали 3 красных и 4 синих капюшона .Затем в темноте на них надели 3 красных и 2 синих капюшона,а остальные капюшоны", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.