Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

тема : Одномерный массив 1)составить текст программы 2)нарисовать блок схему Дан массив из 15 чисел.Определить номер максимального

10-11 класс

элемента в массиве,а также количество отрицательных чисел.

Dro0on 22 янв. 2017 г., 12:16:18 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Зуби
22 янв. 2017 г., 13:56:57 (7 лет назад)

Я так понимаю, что "номер максимального элемента" это на самом деле индекс.(иначе было бы написано "значение максимального элемента") Не забываем, что индексация массива ничинается с нуля.

 

#include <iostream>
using std::cout;
using std::endl;
#include <cstdlib>
using std::rand;
using std::srand;
#include <ctime>
using std::time;

int main()
{
    int a[15];
    int largestIndex = 0, counter = 0;

    srand(time(0));

    for(int i = 0; i < 15; i++)
    {
        a[i] = rand() % 21 - 10;

        if(a[i] < 0)
        {
            counter++;
        }
        if(a[largestIndex] < a[i])
        {
            largestIndex = i;
        }

        cout << a[i] << ' ';
    }

    cout << "\nThe index of the largest number = " << largestIndex
        << "\nThe number of negative elements = " << counter << endl;

   return 0;
}

 

P.S. В другом ответе решение неверное.

+ 0 -
Rim123
22 янв. 2017 г., 14:43:44 (7 лет назад)

Ты не написала в чем решить ну я решу в паскале:

Program Frank;

const n=15;

Type mas=array[1..n] of integer;

var a:mas;max,i,k:integer;

begin

for i:=1 to n do begin

a[i]:=random(100)+5;

writeln(a[i]);

end;

max:=a[1];

for i:=1 to n do begin

if (a[i]>max) then max:=a[i]

end;

writeln('Максимальное число := ',max);

k:=0;

for i:=1 to n do begin

if a[i]<0 then k:=k+1

end;

writeln("Кол-во отрицательных чисел := ",k);

end.

 

 

Ответить

Другие вопросы из категории

ОООЧЕНЬ НУЖНА ПОМОЩЬ! НУЖНО НАПИСАТЬ ПРОГРАММЫ (ХОТЯ БЫ ДВЕ,ПОЖАЛУЙСТА) В ПАСКАЛЕ ABC! 1. Дан массив. Все элементы уменьшить на число a.

2. Дан массив целых чисел. Верно ли,что сумма элементов массива есть четное число.

3. В массиве хранятся сведения о количестве осадков,выпавших за каждый день января. Определить общеее количество осадков за месяц и среднее количество за день.

Как известно, автомобиль, изобретенный Винтиком и Шпунтиком, работает не на бензине, а на газировке разных сортов. На одном литре лимонада он

проезжает 120 км, на одном литре кока-колы — 100 км, на одном литре фанты — 150 км. Цена одного литра фанты в Цветочном городе — 3 монеты за литр, лимонада — 1 монета за литр, кока-колы — 2 монеты за литр. Готовясь к путешествию, Незнайка закупил 10 литров кока-колы, 5 литров лимонада и 10 литров фанты. Винтик и Шпунтик вместе купили 10 литров лимонада и 10 литров фанты. Торопыжка — 5 литров фанты, 10 — кока-колы и 10 — лимонада. Поэт Цветик — 20 литров фанты.

Какая служба предназначена для передачи файлов

1) ICQ

2) FTP

3) WWW

Была произведена серия из 18 подбрасываний монетки. В результате каждого подбрасывания монетка может выпасть орлом или решкой с равной вероятностью.

Сколько бит информации будет нести в себе сообщение о том, что в этой серии было только три выпадения монетки орлом, и все они следовали строго подряд. В ответе укажите целое число.

Читайте также

Ребят, помогите! Тема: одномерные массивы. Две задачи:1) Написать прог

Ребят, помогите! Тема: одномерные массивы. Две задачи:

1) Написать программу, которая из заданного одномерного массива размерности N находит сумму только тех элементов, значения которых больше некоторого значения S.
S=5; Массив: 0,4 5,6 -2 10,1


2) При поступлении в ВУЗ абитуриенты, получившие "Двойку" на первом экзамене, ко второму не допускаются. В массиве A[N] записаны оценки экзаменующихся, полученных на первом экзамене. Подсчитать, сколько человек не допущено ко второму экзамену!

Заранее благодарю!

Составить программу для решения задачи: 1)Даны действительные, положительные числа x,y,z. Выяснить, существует ли треугольник с длинами сторон x,y,z. Если

треугольник, то является ли он равносторонним? 2)Дан одномерный массив. Найти количество смен знака между соседними элементами массива. Программа -Паскаль.

Помогите составить блок-схему алгоритма и программу на алгоритмическом языке программирования БЕЙСИК обработки одномерного массива.Заполнение массива

элементами организовать путем ввода с клавиатуры.В одномерном массиве из N чисел вывести на экран отрицательные элементы и сообщите об их количестве.Пожалуйста,срочно надо.

определить число элементов массива, больших К. По заданному условию сформировать одномерный массив, вывести на печать и произвести операции по обрабо

тке полученных компонентов массива. Исходными данными являются одномерный массив, элементы которого задаются с помощью датчика случайных чисел от -50 до +50 и целое положительное число К



Вы находитесь на странице вопроса "тема : Одномерный массив 1)составить текст программы 2)нарисовать блок схему Дан массив из 15 чисел.Определить номер максимального", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.