Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

помогите!!! Дан массив из n случайных чисел (числа вводятся с клавиатуры).Поменять местами максимальные и минемальные элементы массива

5-9 класс

Knozz1456 29 июня 2014 г., 17:03:25 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Kudilenko
29 июня 2014 г., 19:39:23 (9 лет назад)

Паскаль?
const n=<требуемое число элементов> ;
var a:array [1..n] of integer;
i,i_max,i_min: byte; max,min,x:integer;
begin
writeln(' Введите элементы массива через пробел');
for i:=1 to n do
read(a[i]);
max:=0; min:=1000;
i_max:=0; i_min:=0;
for i:=1 to n do
begin
if a[i]>max then begin max:=a[i]; i_max:=i; end;
if a[i]<min then begin min:=a[i]; i_min:=i; end;
end;
x:=max;
a[i_max]:=min;
a[i_min]:=x;
for i:=1 to n do
write(a[i],'  ');
readln;
end.

Ответить

Другие вопросы из категории

привеидите по одному примеру допустимых и недопустимых значений для каждой из величин:

а)температура человека;
б)скорость автомашины;
в)площадь страны;
г)название дня недели.

РЕШЕНИЕ Скорость передачи v= 32 Кбит/с время передачи t=15 с. объем информации V= v*t=32 Кбит/с *15c=480 Кбит=480000 бит (не путать с байтами)

информационный вес одного символа равен c1= 8 битам количество символов в сообщениии К=V/c1=480000/8=60000 символов на одной странице 48 символов. количество страниц s =60000 символов /48 символов.=1250

Помогите пожалуйста!!!!

4 задание!!!
Заранее спасибо!!!

Читайте также

Задача:

Дан массив из 10 целых чисел,от -20 до 20 .
Напишите программу,заменяющую первый отрицательный элемент массива нулем.

Помогите пожалуйста решить!

1). Дан массив из n элементов (n >= 4). Подсчитать среднюю арифметическую второго и предпоследнего элемента массива.

2). Дан массив из n элементов. Написать программу подсчитывающую произведение элементов массива.

Ребят, помогите пожалуйста. Почти ничего не понимаю в инфе. Дана матрица из целых случайных чисел от 100 до -100. Посчитать в ней колличество

положительных и отрицательных элементов. Найти max и min из положительных и поменять местами.

1)Задан массив из 11 целых чисел. Найти сумму элементов массива, кратных 5 2)Задан массив из 11 целых чисел. Посчитать количество нечётных

элементов массива.

3)задан массив из 9 целых чисел.Вывести на экран чётные элементы



Вы находитесь на странице вопроса "помогите!!! Дан массив из n случайных чисел (числа вводятся с клавиатуры).Поменять местами максимальные и минемальные элементы массива", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.