Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Дано целое число N (N>1). Сформировать и вывести целочисленную последовательность из N чисел Фибоначчи по правилу: первые 2 элемента равны 1, а ка

10-11 класс

ждое следующее, начиная с третьего, равно сумме двух предыдущих.

Dima228874 25 сент. 2014 г., 0:28:42 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
АннаКрот1998
25 сент. 2014 г., 1:13:33 (9 лет назад)

// Примечание: В задании не сказало создать массив, мы его и не создаем!
program fibonachi;
var n, x1, x2, xs, i:integer;
beginx1:=1;
x2:=1;
write ('Введите число N = ');
readln (n);
write (x1, ' ', x2, ' ');
for i:=3 to n do
   begin
    xs:=x1+x2;
    write (xs, ' ');
    x1:=x2;
    x2:=xs;
  end;
end.

+ 0 -
Vasaleksandra
25 сент. 2014 г., 3:02:15 (9 лет назад)

program z;
var a:array[1..1000] of integer; i,n:integer;
begin
write('Введите N (N>1, N<=1000)');
read(n);
a[1]:=1;
a[2]:=1;
write(a[1], ' ', a[2], ' ');
for i:=3 to n do
begin
a[i]:=a[i-2]+a[i-1];
write(a[i], ' ');
end;
end.

Ответить

Другие вопросы из категории

Помогите пожалуйста)) очень-очень срочно(( С# Получить элементы массива А по формуле .... Вычисленый массив вывести на печать.

Найти максимальный по модулю элемент массива А.

Массив я вычислил, а остальное не получается(

using System;

using System.Collections.Generic;

using System.Linq;

using System.Text;

namespace ConsoleApplication27

{

class Program

{

static void Main(string[] args)

{

int n = 30;

double[] a = new double[30];

for (int i = 0; i <= 20; i++)

{

a[i] = Math.Sqrt(i ^ 2 + 1) - Math.Sin(i / n);

Console.WriteLine("a(" + i + ")=" + a[i]);

}Console.ReadKey();

}

}

}


На световой панели в ряд расположены 7 лампочек. Каждая из первых двух лампочек может гореть красным, жёлтым или зелёным цветом. Каждая из остальных

пяти лампочек может гореть одним из двух цветов – красным или белым. Сколько различных сигналов можно передать с помощью панели (все лампочки должны гореть, порядок цветов имеет значение)?

--- Задача 7 ---

Просмотрщик
текстовых файлов. Написать программу, которая позволяет просматривать текстовые
файлы (выводит на экран содержимое файла). Имя просматриваемого файла должно
вводиться с клавиатуры. Вывод содержимого файла произвести постранично.

Примечание:
Результат работы с данными вывести на экран и в новый файл. Файл с входными
данными имеет название INPUT.TXT для текстовых файлов.


на PascakABC оч нужно..плизз

Читайте также

Задачи паскаль, помогите пожалуйста кто. 1, Напишите программу, реализующую следующие вычисления. Дан номер месяца — целое число в диапазоне

1–12, введенное с клавиатуры (1 — январь, 2 — февраль и т. д.). Вывести название соответствующего времени года («зима», «весна», «лето», «осень»).

2, Напишите программу, реализующую следующие вычисления. Дана матрица размера M x N (числа вводятся с клавиатуры). Для каждого столбца матрицы найти произведение его элементов. Полученные значения вывести в текстовый файл.

3, Напишите программу с использованием функции CircleS(R) вещественного типа, находящей площадь круга радиуса R (R — вещественное). С помощью этой функции найти площади трех кругов с данными радиусами. Площадь круга радиуса R вычисляется по формуле S = πR2.

4, Напишите программу, реализующую следующие вычисления. Дано целое число N (1≤N≤26), введенное с клавиатуры. Вывести N первых прописных (то есть заглавных) букв латинского алфавита.

Помогите пожалуйста решить 1) дано натуральное число. Определить номер цифры 3 в нем считая от конца числа. Если такой цифры нет то ответ

0,если их несколько то номер крайней правой.

2) Дано натуральное число. Определить сумму m его последних цифр

3)Дано натуральное число. определить его максимальную цифру.

4) дано предложение. заменить в нем все вхождения под строку str1 на подстроку str2

5) последовательность чисел Фибоначчи образуется так: первый и второй член последовательности равен 1, каждый следующий равен сумме двух предыдущих(1,1,2,3,5,,8,12..) Дано натуральное число n>=3 : а) найти k-й член последовательности б)получить первые n членов последовательности в)для заданного n определить верно ли,что сумма первых n членов есть четное число

ВЫПОЛНИТЬ В ПАСКАЛЕ! Дано целое число N (> 0). С помощью операций деления нацело и взятия остатка от деления определить, имеется ли

в записи числа N цифра «2». Если имеется, то вывести True, если нет — вывести False.

Заранее спасибо :3



Вы находитесь на странице вопроса "Дано целое число N (N&gt;1). Сформировать и вывести целочисленную последовательность из N чисел Фибоначчи по правилу: первые 2 элемента равны 1, а ка", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.