Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

СРОЧНО

5-9 класс

С помощью Паскаля:
1.В магазине продается мастика в ящиках по 15 кг,17 кг,21 кг. Как купить ровно 185 кг мастики, не вскрывая ящики?Сколькими способами можно это сделать?

Sipatova1980 19 февр. 2017 г., 10:56:54 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
ильдар1243
19 февр. 2017 г., 12:41:39 (7 лет назад)

program gt;
var a,b,c,k:integer;
begin
k:=0;
for a:=0 to 12 do
for b:=0 to 10 do
for c:=0 to 8 do
if(a*15+b*17+c*21=185)then begin
k:=k+1;
writeln(a,' ',b,' ',c);
end;
writeln(k,'-кол-во способов');
end.

185/15=12(приблеженно)
185/17=10
185/21=8
т.е 185 div 21=8 ..
выбераем все случаи и находим кол-во
так как больше 12 мастика по 15 кг нельзя(будет >185)
и 10 по 17 и 8 по 21 то перечислим случаи и найдем решение где выполняется все условие

Ответить

Другие вопросы из категории

Опишите, каким образом выполняется функция СЦЕПИТЬ.

В программе MS Excel.

Дмитрий отправляется в школу, которая находится в 1 км от его дома. Дойдя до школы, он вдруг вспоминает, что забыл дома тетради, и поворачивает

назад. Пройдя полпути, он меняет своё решение, посчитав что лучше вернуться в школу до звонка на урок. Пройдя 1/3 км по направлению к школе, он вдруг осознаёт, что не прав и опять меняет направления движения, теперь прежде чем изменить решение, он проходит 1/4 км. Так он и продолжает метаться: после N-го этапа, пройдя 1/N км, снова меняет решение. Надо найти с точностью до 0, 0001 км расстояние от дома до места, где ученик остановился.

Читайте также

Срочно нужна сказка об информатике и

человеке! Буду благодарна! 6 класс Уже 4 раз пишу:с На завтра срочно нужно,не знаю что писать :ссс

Срочно! Напишите сообщение про Системный блок. Рзамером, примерно с альбомный лист.

Только содердательно и понятным языком. Срочно, пожалуйста помогите!

:)

ОЧЕНЬ СРОЧНО!!!!!!!

По каналу один за другим идут пароходы "Обь" и "Восток". Навстречу им идут один за другим пароходы "Мир" и "Енисей". Канал такой ширины, что два парохода в нем разойтись не могут. Но с одной стороны канал имеет расширение, в котором может поместиться один пароход. Как можно пароходам разойтись и продолжить свой путь?
Изобразите решение в виде схемы.ЗАРАНЕЕ СПАСИБО!(объясните,кто как может,очень срочно)

Помогите пожалуйсто решить прошу очень срочно!!!!

1. Чему равны значения переменных r, a, d?
a:=5; b:=20; c:=-7;
d:=2.5;
r := a+(4*b+c)*d;
a:= a+4;
d:=a*7;

2. В пяти тестовых опросах мальчик получил оценки. Составьте программу, которая определит среднее значение оценок, полученных мальчиком в пяти опросах.

3*. Задача. «Покупка в магазине»
Человек делает в магазине покупки. Определите сколько денег у него останется после покупки в магазине перчаток стоимостью А руб., портфеля стоимостью B руб. и галстука стоимостью D руб. Все исходные данные задаются с клавиатуры.

Исходные данные.
a — стоимость перчаток;
b — стоимость портфеля;
d — стоимость галстука;
dengi — количество денег у человека.
Все эти переменные будут вещественного типа.
Результат.
ostatok — количество денег, которое останется у человек (вещественный тип).
Метод решения.
ostatok = dengi – a – b – d
Написать программу, реализующую данную задачу
Помогите пожалуйсто решить очень срочно!!!!!!

пожалуйста срочно помогите, очень прошу

тема у нас Организация ветвлений в Паскале. и так, вопрос:
дано трёхзначное число. если сумма цифр числа кратно 3, тогда перевернуть число, иначе обнулить среднюю цифру
очень срочно, кто может



Вы находитесь на странице вопроса "СРОЧНО", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.