Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

1. Если дано трехзначное число, например 123 его можно представить в

5-9 класс

виде 3+2*10+1*10*10. Воспользовавшись этой информацией, создайте программу,
которая, получая от пользователя трехзначное число, будет определять из каких цифр
оно состоит и выводить их через пробел (например, 1_2_3).

Lizochec 22 янв. 2014 г., 13:22:26 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Avksentyeva
22 янв. 2014 г., 16:00:30 (10 лет назад)

var
a: integer;
begin 
write('Введите число: '); 
readln(a); 
write(a div 100, ' ', a div 10 mod 10, ' ', a mod 10);
end.

+ 0 -
СинийУэй23
22 янв. 2014 г., 18:04:21 (10 лет назад)

эм, паскаль хоть?

+ 0 -
SКристинаs
22 янв. 2014 г., 19:00:09 (10 лет назад)

да,паскаль)

+ 0 -
Fariz1999
22 янв. 2014 г., 21:55:42 (10 лет назад)

ну, я уже добавила решение

+ 0 -
Карина178586
22 янв. 2014 г., 23:32:07 (10 лет назад)

увидела,спасибо;))

Ответить

Другие вопросы из категории

Читайте также

Помогите, пожалуйста, написать программу в Паскаль

Если дано трехзначное число, например 123 его можно представить в виде 3+2*10+1*10*10. Воспользовавшись этой информацией, создайте программу, которая, получая от пользователя трехзначное число, будет определять из каких цифр оно состоит и выводить их через пробел (например, 1_2_3).

Дано трехзначное число. напишите программу, которая определяет:

1) есть ли среди цифр заданного трехзначного числа одинаковые;
Пример входных данных
123 нет
121 да
222 да

2) является ли число '' перевертышем" , т.е. числом , десятичная запись которого читается одинаково слева направо и справа налево.
Пример входных данных
122 нет
121 перевертыш
222 перевертыш

Пожалуйста с примером!!!
Заранее большое спасибо

Задача в Паскале!

Дано трехзначное число - X, выделите его цифры и выведите их в обратном порядке.

ПОМОГИТЕ ПОЖАЛУЙСТА С ДВУМЯ ЗАДАЧАМИ НА ЯЗЫКЕ PASCAL: 1)даны 2 числа, заменить второе число нулем, если оно не меньше первого и оставить его

прежним,если это не так. 2)Даны 3 числа, возвести в квадрат те из них, значения которых не отрицательны, а отрицательные оставить без изменений



Вы находитесь на странице вопроса "1. Если дано трехзначное число, например 123 его можно представить в", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.