Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

плз помогите.. составить программу на языке авс паскаль 1)напишите программу, которая считывает два целых числа a и b

5-9 класс

и выводит наибольше значение из них. Числа - целые от 1 до 1000.

при решении задачи можно пользоваться только целочисленными арифметическими операциями +,-,*,//,%,=. нельзя пользоваться нелинейными конструкциями:ветвления, циклами, функциями вычисления модуля, извлечения квадратного корня., и условными функциями!!!!!!!

2) Дано целое число N. Выведите следующее за ним четное число. При решении задачи нельзя использовать условную инструкцию if и циклы!!

хотя бы формулу:) заранее спасибо)

Kapranova2002 08 июля 2014 г., 11:46:29 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Toshka15
08 июля 2014 г., 13:57:49 (9 лет назад)

//первая программа

var

  a,b:integer;

begin

  write('a = '); readln(a);

  write('b = '); readln(b); 

  writeln('Max(', a, ', ', b, ') = ', (a + b + abs(a - b)) / 2);

end.

 

//вторая программа

var

  n:integer;

begin

  write('n = '); readln(n);

  writeln('Следующее четное число ',  n + 2 - (n + 2) mod 2);

end.

Ответить

Читайте также

Помогите с информатикой! Нужно cоставить программу на языке программирования (Паскаль) с ветвлением

ЗАДАЧА - Составить программу решения задачи: Z = m/(m-1)
ЗАДАЧА - Составить программу определения четных (нечетных) чисел



Помогите составить программу на языке паскаль абц:

Вычислите площадь круга и длину окружности по исходным данным.



Вы находитесь на странице вопроса "плз помогите.. составить программу на языке авс паскаль 1)напишите программу, которая считывает два целых числа a и b", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.