Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Даны действительное число а и натуральное число n. Вычислить. Задача на паскале!!

10-11 класс

p=a(a+1)...(a+n-1)

n=3
p=a(a+1)*(a+2)

лина3656 01 сент. 2014 г., 21:11:44 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Nadya1980
01 сент. 2014 г., 23:47:53 (9 лет назад)

var
  a, p: real;
  n, i: integer;
begin
  p := 1;
  readln(a, n);
  for i := 0 to (n - 1) do
    p := p * (a + i);
  writeln(p);
end.

Ответить

Другие вопросы из категории

Читайте также

Напишите прог-у на паскале... ПЛИИИИИИИИИИЗ 1)даны действительные числа a1, b1, c1, a2, b2, c2. Составьте программу, которая находит координаты точки

пересечения прямых, описываемых уравнениями a1x+b1x=c1 и a2x+b2x=c2. Если прямые пересекаются или не существуют-выдать соответствующее сообщение. 2) даны действительные числа a1, b1, a2, b2. Составьте программу, которая определяет, какая из точек A(a1;b1) или B(a2;b2) лежит на прямой у=2х+1. Если такой точки нет-вывести соответсвующее сообщение.

СРОЧНО ПЛИИИЗ Задача: Дано действительное число Х, вычислить

(x-1)(x-3)(x-7)...(x-63)/(x-2)(x-4)(x-8)...(x-64) (дробь)

Используя оператор: while
Не могу написать через данный оператор программу на паскаль, выходит всегда число 0. Прошу помочь мне :)

Сумма цифр. Даны два числа А и В. Подсчитайте кол-во натуральных чисел на отрезке от А до В , сумма цифр которых четна. Программа

получает на вход два натуральных числа А и В, не превосходящих 10^9^ А<=В . Программа должна вывести одно число - кол-во натуральных чисел, больше или равных А и меньших или равных В, сумма цифр которых четна.



Вы находитесь на странице вопроса "Даны действительное число а и натуральное число n. Вычислить. Задача на паскале!!", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.