Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Привет всем. Помогите написать программы на паскале.

10-11 класс

Сами задачи во вложении.

черепа 19 июня 2013 г., 12:51:13 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Лемп
19 июня 2013 г., 13:23:22 (10 лет назад)

var a:array [1..200,1..200] of integer;
i,b,k,n,m:integer;
begin
writeln ('Введи размерность двумерного массива');
readln (n.m);
writeln ('Введи элементы массива');
for i:=1 to n do
for j:=1 to m do
readln (a[i,j]);
writeln ('Введи число');
Readln (b);
k:=0;
for i:=1 to n do begin
for j:=1 to m do begin
if a[i,j]=b then k:=1;
write (a[i,j]:4);
end;
writeln;
end;
if k=1 then writeln ('Да, такое число есть')
else writeln('Нет, такого числа нет');
readln;
end.

var a:array [1..150,1..150] of integer;
b:array [1..200] of integer;
i,j,k,s,l:integer;
begin
writeln ('Введи размерность квадратной матрицы');
readln (k);
for i:=1 to k do begin
for j:=1 to k do begin
a[i,j]:=random(100)-50;
write (a[i,j]:4);
end;
writeln;
end;
writeln;
for i:=1 to k do
for j:=1 to k do
if i<j then
begin
l:=l+1;
b[l]:=a[i,j];
write (b[l]:4);
s:=s+b[l];
end;
writeln;
writeln ('Сумма получившегося массива= ',s);
readln;
end.

+ 0 -
Natalimamedova
19 июня 2013 г., 15:21:01 (10 лет назад)

Решения нужны к 1 и 3 задаче.

Ответить

Другие вопросы из категории

Дано n, . Вычислить: a1 - a2 + a3- …+ (-1)n+1 an. Дано n, . Получить последовательность , где b1

= a1, b2 = a1+ a2, …, bn = a1+ an. Дано n. Получить последовательность , где Даны n,. Получить сумму и количество тех элементов данной последовательности, которые кратны 5 и не кратны 4. Даны n,. Вычислить Даны n и . Получить a1, a2, …, an , 2a1, 3a2, …, (n + 1)n an. Выяснить образуют ли они возрастающую последовательность.

Помогите сделать 1 номер
Определить, кто из четырех студентов сдал экзамен,

если известно:
1) Если первый сдал, то и второй сдал;
2) Если второй сдал, то третий сдал или первый не сдал;
3) Если четвертый не сдал, то первый сдал, а третий не сдал;
4) Если четвертый сдал, то и первый сдал.

Pascal

Найти сумму всех двухзначных чисел, которые кратны трём.

Читайте также

написать программу на Assembler

добрый вечер, всем. помогите, пожалуйста, написать программу на Ассемблере.

задание:
Создать программу на языке Ассемблер, что позволяет организовать вычисления над элементами массивов

Объединить два массива 8-битных целых чисел со знаком. Сначала элементы второго затем первого.

заранее огромное спасибо всем!

Помогите написать программу в паскале. Задание:На плоскости даны 2 точки А (х1; у2) и В (х2; у2), определить какая из них находится дальше от начала коо

рдинат. Я поняла, что нужно найти их длины (формулы я знаю), а правильно написать программу не могу

Помогите написать программу по Информатике! Найти произведение двузначных нечетных чисел, кратных

13.

Нужно написать программу на цикле с предусловием, на Паскале.

Помогите написать программу на C#

Дано натуральное число n. Написать программу вычисляющую сумму



Вы находитесь на странице вопроса "Привет всем. Помогите написать программы на паскале.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.