Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

найти максимальных элемент в массиве размерностью М*Т.М и N вводятся с клавиатуры. (Паскаль)

10-11 класс

кищук 29 авг. 2014 г., 23:51:47 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Ksgfkgf
30 авг. 2014 г., 2:07:40 (9 лет назад)

var
A: array [1..100, 1..100] of integer;
max,i,j,m,n: integer;

begin
randomize;
writeln('Введите размеры массива MxN: ');
readln(m,n);
for i:=1 to m do 
 for j:=1 to n do 
  A[i,j]:=random(101);
writeln('Массив: '); 
for i:=1 to m do
 begin 
  for j:=1 to n do write(A[i,j]:4);
  writeln;
 end;
max:=A[1,1]; 
for i:=1 to m do
 for j:=1 to n do
  if max < A[i,j] then max:=A[i,j];
writeln('Максимальный элемент = ',max);
end.  

Ответить

Читайте также

Паскаль помогите пжл!!!!!! Дан одномерный массив, состоящий из вещественных элементов. Найти произведение элементов массива,

расположенных между максимальным и минимальным элементами.

Дан одномерный массив, состоящий из вещественных элементов. Найти произведение элементов массива, расположенных между максимальным по модулю и минимальным по модулю элементами

ну или исправьте мое пжл

program fgf;
var mas:array[1..100] of real;
max,min:real;
i,n,c,b:shortint;
p:real;
f1,g:text;
begin;
assign (f1, 'input.txt');
reset (f1);
readln (f1, n);

for i:=1 to N do read (mas[i]);
max:=mas[i];
for i:=2 to N do begin
if mas[i]>max then begin
max:=mas[i];
c:=i;
end;
end;
min:=mas[1];
for i:=2 to N do begin
if mas[i]<min then begin
max:=mas[i];
b:=i;
end;
end;
close(f1);
assign (g, 'output.txt');
rewrite (g);
p:=1;
if b<c then I:=b+1 and c-1

else for I:=c+1 to b-1 do p:=p*mas[i];

if (n<3) or (b+1=c) or (c+1=b) then writeln(g,'0.00') else write(p:3:3) ;

close (g);
end.

HELP ME!! задан массив размерностью (10х10) элементов. присвоить элементам массиваизначение функции Y=cos(x^0.25-0.5x^0.5+0.25x^0.75) при изменении

аргумента от 6 с шагом 0.25.
найти максимальный элемент массива. сформулировать новый массив путем вычеркивания строки и столбца, на которых расположен максимальный элемент.
вывести на экран в формате 3 знака после запятой:
1. исходный массив
2. полученный массив
3. искомые элементы ( если они есть)
предесмотреть возможность вывода на экран и в файл....

1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы

каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3. Ввести массив с клавиатуры, найти и вывести сумму элементов массива. 4. Ввести массив с клавиатуры, подсчитать, сколько в нем положительных элементов, а сколько отрицательных. 5. В одномерном массиве подсчитать, сколько отрицательных элементов находится на четных местах и сколько положительных на нечетных. 6. Элементы массива вводятся с клавиатуры, заменить в нем все отрицательные элементы их квадратами, а положительные кубами. Вывести на экран исходный и новый массив. 7. Ввести массив с клавиатуры, найти и вывести на экран максимальный и минимальный элементы. 8. Написать программу, которая определяет есть ли в массиве элемент введенный пользователем, подсчитывает их количество и выводит номер первого найденного элемента.

написать программы 1)В одномерном массиве с(1:10) найти количество элементов удовлетвор. условию с от i >q и с от i<l . 2)Найти

минимальный и максимальный элемент массива и его индекс .

Ввести одномерный массив A, вывести его. Переставить в обратном

порядке все элементы между максимальным и предпоследним
отрицательным элементом.
Помогите, не могу найти предпоследний элемент в массиве, и как их переставить?



Вы находитесь на странице вопроса "найти максимальных элемент в массиве размерностью М*Т.М и N вводятся с клавиатуры. (Паскаль)", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.