Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Заданы размеры сторон a, b, c некоторой детали в виде параллелепипеда, количество штук деталей K, размеры сторон тары для упаковки деталей, имеющей также

10-11 класс

форму параллелепипеда A, B, C. Вычислить объем детали v, объем тары V, необходимое количество тары N для упаковки деталей количеством K штук. Если N>10, то вычислить отношение объема детали к объему тары .
Помогите пожалуйста написать это В Паскале.

Beemo 04 дек. 2014 г., 10:23:37 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Solomonova2001лера
04 дек. 2014 г., 12:21:10 (9 лет назад)

var a,b,c,at,bt,ct,v,vt,k,n,n1:real;
begin
write('Размеры детали: ');
readln(a,b,c);
write('Размеры тары: ');
readln(at,bt,ct);
write('Количество деталей: ');
readln(k);
v:=a*b*c;
vt:=at*bt*ct;
n1:=int(vt/v);
n:=int(k/n1);
if frac(k/n1)>0 then n:=n+1;
writeln ('Необходимое количество тары: ',n);
if n>10 then writeln('Отношение объемов: ',v/vt);
end.

Ответить

Другие вопросы из категории

Уильям Вингейт предлагает услуги по учету пиццы. Для каждой пиццы он записы-

вает такую информацию:

• Имя компании-производителя пиццы, которое может содержать более одного слова

• Диаметр пиццы

• Вес пиццы

Придумайте
структуру, которая может хранить такую информацию, и напишите
программу, в которой используется переменная специального типа для такой
структуры. Программа должна предлагать пользователю ввести данные для
каждого из названных пунктов и затем выводить эту информацию.
Используйте объекты cin (или его методы) и COUt.

5. Напишите
программу к упражнению 2, но используйте оператор new для выделе­ния
структуре области памяти вместо объявления структурной переменной.
Про­грамма должна также запрашивать диаметр пиццы до запроса названия
компа­нии — производителя пиццы

как объединить три столбца?

ЕСЛИ(F2>25;"мастер";" ")
ЕСЛИ(И(F2>10;F2<25); "КМС";" ")
ЕСЛИ(И(F2>0;F2<10); "Любитель";"
")

Из чего состоит компьютер?

Читайте также

Создать на Паскале форму.

1. Население некоторой страны в 1904 году составляло а человек. По переписи населения, проведенной в прошлом году, зарегистрировано b человек. Составить программу вычисления среднегодового прироста населения за этот период.
2. Составить программу определения, является ли введенный год високосным?
3. Составить программу определения размера денежного вклада через t лет после его внесения, если заданы размер начального взноса n и банковский процент b.
4. Для условий из предыдущей задачи определить, через сколько лет размер вклада превысит вдвое первоначальный взнос.

Задача 1. Счастливые билетики по–ярославски

Есть счастливые билетики по–московски, есть счастливые билетики по–питерски, но мало кто слышал про счастливые билетики по–ярославски. В ярославском общественном транспорте номера билетиков состоят из 2N цифр. Билетик называется счастливым, если ярославская сумма первых N цифр равна ярославской сумме последних N цифр. Требуется найти количество счастливых билетиков по–ярославски для заданного N. На первый взгляд, задача простая, но что же такое «ярославская сумма»? Для заданного числа k найдем сумму его цифр, если получившееся число состоит из двух и более цифр, то найдем сумму цифр этого числа и т. д., пока не получим число, состоящее из одной цифры. Такая сумма цифр называется «ярославской суммой цифр». Билетики нумеруются от 00…000 до 99…999.
Вход: файл input.txt, в первой строке которого записано натуральное число N.
Ограничения: 1 ≤ N ≤ 1000
Выход: файл output.txt, содержащий одно число – количество счастливых билетиков по модулю109+7 (т.е. остаток от деления количества счастливых билетиков на 109+7)
Примеры
input.txt output.txt
1 10
6 110888113
Задача 2. Замощение улицы
Новый мэр Эль-Пасо Авраам Гарфилд решил замостить главную улицу города и для этой работы нанял бригаду рабочих во главе с Джорджем Шерманом. Улица представляет собой полосу длиной 4*N метров. Бригада Джорджа будет покрывать её плитками размера 1*2 метра. Плитки можно укладывать как горизонтально, так и вертикально. Шермана интересует, сколькими способами он может замостить главную улицу Эль-Пасо. Так как это число может быть очень большим, то от вас требуется найти число замощений по модулю 109+7 (т.е. найти остаток от деления количества замощений при делении на 109+7).
Вход: файл input.txt, в первой строке которого записано натуральное число N (ширина дороги в Эль-Пасо).
Ограничения: 0 < N < 113
Выход: файл output.txt, содержащий одно число – количество различных способов замостить улицу плитками 1*2 по модулю 109+7 (т.е. остаток от деления количества способов замостить улицу на 109+7).
Примеры
input.txt output.txt
2 5
3 11
7 781
Пояснение к примерам
Улицу длиной 4*2 метра (первый тест из примеров) можно замостить 5 следующими способами:

Задача 3. Упаковка печенья
На вас, как на главном программисте компании по производству печенья, лежит много ответственных заданий. Одно из них – производство и упаковка печенек должна соответствовать самым высоким требованиям Ярославского Консорциума по упаковке печенья.
В любой момент ваша линия производства выпускает новые печеньки, которые хранятся в печенькохранилище, ожидая упаковки. Время от времени поступают запросы с конвейера по упаковке – отправить из печенькохранилища ту печеньку, которую нужно упаковать. Перед поступлением в хранилище, диаметр каждой печеньки измеряется с точностью до 1 нанометра. На упаковку отправляется печенька, являющаяся медианой среди всех печенек. Что такое медиана? Если мы отсортируем печеньки по возрастанию диаметров, то, если печенек нечетное количество c, то на упаковку идёт печенька на позиции (c+1)/2 в отсортированной последовательности. Если же c – четное число, то печенька на c/2+1 в отсортированной последовательности. Если печеньку отправляют на упаковку, то она пропадает со склада. Ваша задача – промоделировать работу системы упаковки печенек.
Вход: файл input.txt, в каждой входной строке которого содержится либо положительное число d, означающее, что в хранилище поступает новая печенька диаметром d нанометров, либо символ '#', означающий запрос с конвейера по упаковке.
Ограничения: 1 ≤ d ≤ 300 000 000; количество строк ввода не более 600 000; также следует считать, что хранилище пусто до тех пор, пока туда не поступит первая печенька.
Выход: файл output.txt, содержащий несколько строк – после каждого запроса на упаковку в отдельную строку выводится диаметр печеньки, которая отправляется на упаковку.
Примеры
input.txt output.txt
1
2
3
4
#
#
#
# 3
2
1
4
1
#
2
#
3
#
4
# 1
2
3
4





Вы находитесь на странице вопроса "Заданы размеры сторон a, b, c некоторой детали в виде параллелепипеда, количество штук деталей K, размеры сторон тары для упаковки деталей, имеющей также", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.