Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Помогите решить задание С2 из Егэ

10-11 класс

Дан целочисленный массив из 30 элементов. Элементы массива могут принимать значение от -1000 до 1000.Гарантируется, что последний элемент массива отличен от нуля.
Приведите фрагмент программы вместо ... на языке Паскаль.
const N=30;
var
a: array [1..N] of integer;
i, x, y: integer;
s: real;
begin
for i;=1 to N do readln(a[i]);
.......
end.
ниже скрин задания.

Принцеса8 12 апр. 2014 г., 1:21:24 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Nasty26103
12 апр. 2014 г., 1:56:17 (10 лет назад)

x:=0; y:=0;
for i:=1 to N do begin
if A[i] mod A[N]=0 then begin x:=x+A[i]; y=y+1; end;
end;
writeln(x/y:0:2);

Ответить

Другие вопросы из категории

на СИ,пожалуйста

Дано действительное число а.Вычислить выражение
(а-2)(а-4)(а-8)...(а-64):(а-1)(а-3)(а-7)...(а-63)

y={a-sin(x). если x<a √x+a+1, во всех других

Читайте также

Помогите решить задачу.

Дан массив А1,.......Аn. найти максимальный и минимальный элементы и поменять их местами. Вот задача которую я делал:

program zadacha;
const
k=50;
var
a:array[1..k] of integer;
n,i:1..k;
c,v,max,min,prom:integer;
begin
for i:=1 to n do begin (здесь выскакивает ошибка о проверки диапазона)
a[i]:=random(50);
write(a[i],' ');
end;
max:=a[1];
min:=a[1];
for i:=1 to n do begin
if a[i]>max then begin
max:=a[i];
c:=i;
end;
if a[i]<min the begin
min:=a[i];
v:=i;
end;
end;
writeln('max=',max,'min=',min);
prom:=max; (вот с этой строчки и до конца помогите решить)
max:=min;
min:=prom;
writeln;
writeln('Полученный массив');
for i:=1 to n do
write(a[i], ' ');
readln;
end.

Здравствуйте! Помогите решить задания! Не понимаю программу Кумир, к сожалению, завтра последняя возможность исправить оценку. заранее

спасибо

1. Напечатать числовой ряд: 1,7,13,19,25,31,……….61 с помощью цикла «пока».

2. Написать программу, которая запрашивает число с клавиатуры и сообщает его квадрат, затем спрашивает пользователя «Нужно продолжить работу?», и пользователь отвечаетда/нет. Программа заканчивает свою работу, если пользователь напечатал слово «нет» на очередной вопрос программы, иначе считает и выдаёт ответ дальше.

3. Дан массив из 10-ти чётных натуральных чисел – от 2 до 20.

А) Найдите сумму элементов массива.

Б) Найдите минимальный элемент массива.

4. Дан массив из 15 подряд идущих натуральных чисел, начиная с 50.

А) Найдите произведение элементов массива.

Б) Найдите максимальный элемент массива.

помогите решить задание

ответ будет 9
мне решение надо, я разобраться не могу

Помогите решить задание 5.


Вы находитесь на странице вопроса "Помогите решить задание С2 из Егэ", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.