Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Делится ли заданное число на два?

5-9 класс

911Bond007 23 нояб. 2014 г., 0:30:34 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Danillevanov0
23 нояб. 2014 г., 2:55:15 (9 лет назад)

вообще признак делимости на 2 можно определить проще. Если остаток от деления на 2=0 тогда число делится на 2 нацело иначе нет if (n mod 2)=0  then writeln('Число  делится на 2 нацело' ) else   writeln('Число не  делиться на 2 нацело' ); Однако если по условию задачи признак, такой то уж ничего не пделаешь  Program evenNum; Uses crt; var n:real; begin      clrscr;         write('Введите число n: ');      readln(n);         if ((n/2)<>(n div 2)) then writeln('Число не делится на 2 нацело' )                  else   writeln('Число  делится на 2 нацело' );      readkey;       end.     

+ 0 -
RuslanRUS
23 нояб. 2014 г., 4:01:55 (9 лет назад)

Любые четные числа делятся на 2 без остатка. Например: 2:2=1, 4:2=2, 6:2=3 и так далее.
Если число не четное, то оно делится на 2 с остатком, например: 2,5:2=1,25 , 93:2=46,5 и так далее.

+ 0 -
Svetast80
23 нояб. 2014 г., 6:45:17 (9 лет назад)

какое число?

+ 0 -
Missshatova
23 нояб. 2014 г., 8:44:14 (9 лет назад)

число любое ....

+ 0 -
Bersteneva98
23 нояб. 2014 г., 9:46:14 (9 лет назад)

Что делать надо?

Ответить

Другие вопросы из категории

Действия с информацией - это действия с…

Продолжите пожалуйста!

Запишите значения переменной b после выполнения фрагмента алгоритма.

В ответе укажите одно число-значение переменной b

1)Составьте программу, которая заполняет массив a [1...10] случайными целыми числами в диапазоне от 1 до 20 и вывода на экран элементов массива с

нечётными значениями.
2) Соединить :D
1- двоичный код
2- кодирование
3- система счисления
4- основание
5- разряд
а- Процесс преобразования информации из одной форму представления в другую
б- Набор из нулей и едениц
в- Позиция цифры в числе
г- Способ запичи чисел
д- Число цифр, которые используются в системе счисления для записи чисел

Читайте также

Определить, делится ли первое число на другое без остатка.

Сначала строим информационную модель устно.

Во-первых, вводятся числа А и В.

Находим остаток от деления числа А на число В.

Если остаток от деления равен нулшю, то выводим результат: Число А делится на число В без остатка

Иначе

Результат – Число А делится на число В с остатком.

Составить блок-схему и программу определяющую делится ли первое число на второе.

(использовать команду mod и div с формулой a:=b mod c)

Ребят, помогите с:

"Проверить делится ли вводимое число на 5;11.
( В ПАСКАЛЕ)"
Буду благодарен :з



Вы находитесь на странице вопроса "Делится ли заданное число на два?", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.