Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Все элементы кратные 10 заменить нулем остальные оставить без изменения. Помогите решить язык C++

10-11 класс

89370665664 25 сент. 2016 г., 16:47:07 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Evnea0
25 сент. 2016 г., 18:20:31 (7 лет назад)

#include<iostream>
using namespace std;
int main(){
int a[1000],i,n;
cin>>n;
for(i=1;i<=n;i++){
cin>>a[i];
if(a[i]%10==0) a[i]=0;
}
for(i=1;i<=n;i++){
cout<<a[i]<<" ";
}
return 0;
}

Ответить

Другие вопросы из категории

Написать программу вычесления стоимости покупк,состоящей из нескольких тетрадей и токого же кол-во обложек к ним.Ниже представлен рекамендующий вид

экрана во время работы программы вычесления стоимости покупки введите исходные даные:

цена тетради (руб)-2.75

цена карандаша(рую)-0.5

кол-во комплектов(шт)-7

стоимость покупки-22.75 руб!

Пожалуйста, помогите с информатикой

Просто умоляю вас
Задание 1: Посчитайте, сколько всего компьютеров может быть в Интернете. Расчет с необходимыми пояснениями запишите в тетрадь.
Задание 2: При помощи любой известной вам поисковой системы определите число документов Интернет, в которых цитируется описание IP. Попробуйте найти собственно описание протокола. (документ RFC - 791)

Перевести числа: - 4007 из восьмеричной в десятичную систему, - 1111 из двоичной в

десятичную,

- 4007 из десятичной в восьмеричную,

- 4007 из десятичной в двоичную.

Составить программу нахождения наибольшего элемента в линейном массиве, используя вспомогательные процедуры нахождения наибольшего из двух чисел и

создания массива случайных чисел.

начало
создание массива Tabl
z:=a[1]
i:=2,n
Max(z, a[i],z)
вывод Max
конец

Читайте также

Помогите, пожалуйста, решить задачу в Паскале (программа выводит не правильный результат, а понять где допущены ошибки не могу).

Задать массив из 30 положительных элементов случайным образом.
• найти кол-во нечётных элементов всего массива;
• найти минимальный элемент;
• элементы, кратные 10, заменить единицами и вывести новый массив.

1.Одномерный массив заполнен случайным образом. Найти количество четных элементов. 2. Одномерный массив размерностью N , где N -нечетное число,

заполнен случайными числами от -15 до 6. Все , числа кратные 3 заменить на противоположные.



Вы находитесь на странице вопроса "Все элементы кратные 10 заменить нулем остальные оставить без изменения. Помогите решить язык C++", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.