Статистика
Всего в нашей базе более 4 327 657 вопросов и 6 445 963 ответов!

помогите с паскалем

5-9 класс

1. написать алгоритм нахождения максимального среди 4 целых чисел.
2. написать алгоритм проверки: имеются ли среди трех целых чисел два положительных значения.
3. написать алгоритм проверки: лежит ли точка с координатами х;у в первой координатной четверти?

Dasha2603 27 марта 2017 г., 5:59:04 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
эльнурка
27 марта 2017 г., 8:22:16 (7 лет назад)

var a,b,c: integer;
begin
for a : = 1 to 4 do
begin
readln ( b) ;
if b > c then c:=b;
end;
end.

var a, b, c: integer;
begin
for b:=1 to 3 do
begin
readln ( a );
if a > 0 then c:= c+1;
end;
if c =2 then write ('est');
 end.

Ответить

Другие вопросы из категории

Напишите пожалуйсто условие и решение на языке паскаля+

Вкладчик положил в банк 1500 у. е. ежегодно сумма вклада увеличивается на 3%. Через сколько лет сумма вклада составит 3000 у. е.

В некотором

каталоге хранился файл Задача. После того, как в этом каталоге создали
подкаталог и переместили в созданный подкаталог файл Задача, полное имя файла
стало Е:\Школа\Уроки\Задачник\Задача. Каково было полное имя этого файла до
перемещения?











Выберите
один из 4 вариантов ответа:

1)
Е:\Уроки\Задачник\Задача

2)
Е:\Уроки\Задача

3)
Е:\Школа\Задачник\Задача

4)
Е:\Школа\Уроки\Задача

К каким типам данных относятся следующие значения:

а) 54.06 b) “abc” c) ложь d) -1.3 e) “123” f) 15/06/96 ?

ВАРИАНТЫ ВОЗМОЖНЫХ ОТВЕТОВ:числовой,символьный,дата,логический.

Читайте также

Добрый день,помогите с паскалем

Нужно размножить снежинку и чтобы она появлялась в рандомных местах
Uses GraphABC;
var y, i, x: integer;
begin
moveto(0,320);
lineto(2000,320);
Line(120,100,80,140);
Line(120,100,160,140);
Line(120,160,80,200);
Line(120,160,160,200);
Line(120,220,80,260);
Line(120,220,160,260);
Line(120,100,120,320);


Rectangle(260,180,400,320);
Line(260,180,340,100);
line(340,100,400,180);
Rectangle(300,220,340,260);
Line(300,240,340,240);
line(320,220,320,260);
Rectangle(300,280,340,320);








for i := 1 to 10 do begin
x := random (1024);
y := random (200);





line(440,60,480,100);
line(440,80,480,80);
line(480,60,440,100);
Line(460,60,460,100);

Rectangle(460,200,500,320);
Line(460,220,500,220);
Line(460,240,500,240);
Line(460,260,500,260);
Line(460,280,500,280);
Line(460,300,500,300);
Line(500,200,560,200);
line(560,200,640,320);
line(500,320,640,320);

Circle(760,280,40);
Circle(760,220,20);
Circle(760,190,10);


Line(500,120,540,120);
line(600,20,600,60);
Line(600,180,600,220);
Line(660,120,700,120);
Circle(600,120,40);

FloodFill(140,440,clSkyBlue);
FloodFill(160,380,clSkyBlue);
FloodFill(160,350,clSkyBlue);
FloodFill(320,200,clGray);
FloodFill(310,230,clYellow);
FloodFill(330,230,clYellow);
FloodFill(310,250,clYellow);
FloodFill(330,250,clYellow);
FloodFill(302,20,clSilver);
FloodFill(600,140,clYellow);
FloodFill(320,300,clBrown);
FloodFill(320,160,clRed);
FloodFill(540,250,clTeal);
FloodFill(480,210,clMaroon);
FloodFill(480,230,clMaroon);
FloodFill(480,250,clMaroon);
FloodFill(480,270,clMaroon);
FloodFill(480,290,clMaroon);
FloodFill(480,310,clMaroon);


end;
end.

составьте программу для определения,что больше площадь круга радиусом a или площадь квадрата со стороной a-значения числа a вводятся с

клавиатуры(площадь круга вычисляется по формуле:S=PR^2)помогите пожалуйста:(

паскаль

Помогите пожалуйста!Паскаль ABC

Составьте программу, определяющую минимальное из всех введенных вами чисел (число 99 - конец цикла).

Запросите и введите с клавиатуры имя пользователя, имя его друга(подруги) и суть отношений между ними(дружба, любовь).

Напечатайте на экране:
<имя 1>+<имя 2>=<отношения>
помогите на паскале



Вы находитесь на странице вопроса "помогите с паскалем", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.