Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

Составить программу на паскале, которая печатает true, если точка с координатами (x,y)ринадлежит заштрихованной области, и false в противном случает.

5-9 класс

Ссылка на картинку: http://s019.radikal.ru/i614/1205/29/6f207a690a88.jpg

Bagira70 04 дек. 2016 г., 21:30:59 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Genaserduk
05 дек. 2016 г., 0:03:26 (7 лет назад)

uses crt;
var x,y,z:integer;
begin
clrscr;
writeln('Vvedite x,y');
readln(x,y);
if (x<0) and (y>0)
then
begin
if (sqr(x)+sqr(y)< 36) then writeln('True') else
writeln('False');
end else
if (x>0) and (y>0) and (sqr(x)+sqr(y)>9) and(sqr(x)+sqr(y)<36) then writeln('True')
else writeln('False');
readln();
end.

Ответить

Другие вопросы из категории

Помогите решить кроссворд по информатики

1. Признаки, по которым один класс объектов отличается от другого, называется: ... Классификации.
2. Классификация, в качестве основания которой взяты существенные признаки объектов
3. Схему отношения "Является разновидностью " называют схемой ... .
4. Классификация, в качестве основания которой взяты несущественные признаки объектов.
5. Совокупность, набор, коллекция объектов.
6. Деление множества объектов на классы.
7. Часть элементов некоторого множества.
8. Подмножество объектов, имеющих общие признаки.
9. Основные, самые важные признаки объекта.

Читайте также

Помогите пожалуйста решить!)

Составить программу, которая печатает true, если точка с координатами (х, у) принадлежит заштрихованной области, и false в противном случае:

Помогите решить задачки на паскале я совсем не разбираюсь в этом!!! 1)Дана таблица со значениями среднемесячных температур в течение года. Составить

программу на Паскале, в которой вычисляются четыре величины: средние температуры зимних месяцев, весенних месяцев, летних и осенних. 2)Вы посетили магазин и купили 10 видов товара. В таблицу T [1..10] записали количество купленного товара каждого вида. В таблицу C [1..10] записали цену единицы каждого вида товара соответственно. Составить программу на Паскале вычисления общей стоимости всех покупок.

Поомогите, пожайлуста. Нужно составить программу на паскале. Ежемесячная стипендия студента составляет a руб.Расходы на проживание превышают стипендию

и составляют b руб(в месяц).Рост цен ежемесячно увеличивает расходы на 3%,составьте программу расчета необходимой суммы денег,которую нужно единовременно попросить у родителей,чтобы можно было прожить 10 месяцев,используя эти деньги.



Вы находитесь на странице вопроса "Составить программу на паскале, которая печатает true, если точка с координатами (x,y)ринадлежит заштрихованной области, и false в противном случает.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.