Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

опишите на русском языке или одном из языков программирования алгоритм получения из заданного целочисленного массива размером 30 элементов другого массива

10-11 класс

,который будет содержать противоположные значения элементов первого массива

Gfgf14 08 янв. 2015 г., 9:19:23 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Demen17
08 янв. 2015 г., 9:56:14 (9 лет назад)

var
  a, k: array [1..30] of integer;
  i: byte;

begin
  for i := 1 to 30 do
  begin
    a[i] := random(255);
    writeln(String.Format('a[{0}] => {1} |', i, a[i]));
  end;
  for i := 1 to 30 do
    k[i] := -1 * a[i];
  for i := 1 to 30 do
    writeln(String.Format('k[{0}] => {1} |', i, k[i]));
end.

Ответить

Другие вопросы из категории

Помогите написать программу на с++.

Напишите функцию, которая вычисляет значение ab. Числа a и b могут быть любыми дробными положительными числами. И программу, использующую эту функцию для вывода результата на экран.

Может кто помочь?......

Читайте также

дан целостный массив из 30 элементов. элементы массива могут принимать целые значения от 0 до 100 опишите на русском языке или одном из языков

программирования алгоритм позволяющий найти и вывести номер элемента массива имеющего максимальное значение сре элементов массива которые делятся на 3 и кратны 5

Опишите на русском языке или одном из языков

программирования алгоритм поиска номера первого из двух последовательных
элементов в целочисленном массиве из 30 элементов, сумма которых максимальна
(если таких пар несколько, то можно выбрать любую из них).
Тремя способами: когда запоминается первый элемент, i бежит по второму элементу, не запоминая сумму элементов, а только номер.

ПАСКАЛЬ.1)дан целочисленный массив из 30 элементов.элементы массива могут принимать целые значения от 0 до 1000.опишите на русском языке или на одном из

языков программирования алгоритм,позволяющий найти среднее арифметическое нечетных трехзначных чисел,записанных в этом массиве.если ни одного такого числа нет,нужно вывести сообщение об этом.
2)дан целочисленный массив из 30 элементов.элементы массива могут принимать целые значения от 0 до 100.опишите на русском языке или на одном из языков программирования алгоритм,позволяющий найти и вывести произведение элементов массива,которые имеют четное значение и не оканчиваются на 0.

СРОЧНО!!! Дан целочисленный массив из 30 элементов, все элементы которого – неотрицательные числа, не превосходящие 10000. Опишите на русском

языке или на одном из языков программирования алгоритм, который находит и выводит минимальное трехзначное число, записанное в этом массиве. если таких чисел нет, нужно вывести сообщение «Таких чисел нет».

объяните решение пожалуйста программу не обязательно писать

Решение есть.нужно его объяснить.Опишите на русском языке или на одном из языков программирования алгоритм вычисления разности максимального среди

элементов, имеющих четные значения, и максимального среди элементов имеющих нечетные значения, в заданном целочисленном массиве из 30 положительных элементов.Cоnst N = 30; Var a: array [1..N] of integer; MaxEv, MaxOdd, I: integer; begin for i=1 to N readln(a); MaxEv :=0; MaxOdd :=0; For I :=1 to N do if (a div 2)*2 = a then begin if a >= MaxEv then MaxEv :=a; end else if a >= MaxOdd then MaxOdd :=a; Writeln (MaxEv - MaxOdd); end.



Вы находитесь на странице вопроса "опишите на русском языке или одном из языков программирования алгоритм получения из заданного целочисленного массива размером 30 элементов другого массива", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.