Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Пусть дано 100 целых чисел, которые вводятся по одному. Найдите количество элементов больших числа 10 и кратных 3

10-11 класс

Dashulya183458 30 окт. 2014 г., 17:00:25 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
мейцер
30 окт. 2014 г., 19:15:08 (9 лет назад)

Program Pr1;
uses crt;
var mas:array[1..100] of integer;
i,a:integer;
Begin
clrscr;
a:=0;
for i:=1 to 100 do begin
read(mas[i]);
if (mas[i]>100) and (mas[i] mod 3=0) then a:=a+1;
end;
writeln(a);
end.

Ответить

Читайте также

Дан массив, состоящий из 100 целых чисел:

а) Вывести все числа, которые встречаются в этом массиве по нескольку раз;
б) Вывести все числа, которые встречаются в массиве только по одному разу.

Задачи на записи и файлы. № 1. Пусть дан файл целых чисел. Определите длину наибольшего интервала возрастания и среднее арифметическое чисел этого

интервала. № 2. Имеется типизированный файл с числами. Изменить все его элементы, порядковый номер которых кратен трем. Новые значения вводятся с клавиатуры. Размер существующего файла неизвестен.

Составить программу Дан массив натуральных чисел , размерность -12 !) Заполнение массива производить с клавиатуры 2) Вывести на печать

только элементы кратные 2

3)Найти сумму первых пяти элементов

Составить программу Дан массив целых чисел , размерность -12

1) Заполнение массива производить случайными числами из диапозона [-10;35]

2)Вывести на печать только положительные элементы

3)Найти количество отрицательных элементов

Составить программу

Известны данные о выпуске прождукции ( ткани в метрах ) ткацким цехом текстильного комбината за каждый день месяца . Определить количество ткани ( метров) произведенных цехом за месяц .

Пожалуста!!!!!!!!!!!!!!!!!!!!!!ОЧ срочно!!!!!! Написать программу на паскале, которая вводит

массив из N целых чисел и выводит на экран номера отрицательных элементов и сами эти элементы. Протестировать программу для следующих массивов:

а) 3 5 -2 0 -6 -8 1

б) -1 -2 -3 0 -1 2 3

массивы должны вводися вручную а не рандомно.

Пусть дан одномерный числовой массив, составленный из целых чисел. Его можно получить либо вводом с клавиатуры командой Input либо выбором из ячеек

рабочего листа. Количество элементов заранее неизвестно.
Сформировать из элементов заданного массива чисел новый той же размерности по правилу: Xj = Yj + j.
Нужно сделать в Excel VBA
Помогите пожалуйста



Вы находитесь на странице вопроса "Пусть дано 100 целых чисел, которые вводятся по одному. Найдите количество элементов больших числа 10 и кратных 3", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.