Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Программа на языке паскаль сравнить 2 числа а и б если число а>б, то тогда б=а2

5-9 класс

если а=б, то без изменений
если а<б, то б=корень а

НААААААААААААААСТЯ 27 марта 2015 г., 11:43:45 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
ДомвёноК
27 марта 2015 г., 13:58:19 (9 лет назад)

program zadanie;
var a,b:real;
beginreadln(a,b);
if (a > b)  then b := sqr(a)else if(a < b) then b:=sqrt(a);
writeln(b);
readln;
end.

Ответить

Другие вопросы из категории

вот это нужно)решиить
Автомат получает на вход пятизначное десятичное число. По полученному числу строится новое десятичное число по следующим правилам:

1. Вычесляются два числа - сумма первой, третьей и пятой цифр и сумма второй и четвертой цифр заданного числа.
2. Полученные два числа записываются друг за другом в порядке неубывания (безразделителей) .
Определите, сколько из приведенных ниже чисел могут получиться в результате работы автомата. 40 1030 130 1320 2019 1920 2013 213 3010

В документе 1190 стр. На каждой странице текст расположен в 2 колонки . В каждой колонке 75 строк, а в каждой строке по 65 символов .

Вычислите кол-во информации, содержащейся в документе словаре . Представьте это кол-во в битах, байтах и в производных от них единицах.

розвязок ребуса 7 i=о

Читайте также

Плиз срочно надо.1)Найдите правильную на языке паскаль запись выражения

19(16,3+7,7).а)19(16.3+7.7),в)19*(16.3+7.7).д)19(16,3+7.7).с)19*(16.3+7.7).2)Найдите правильную на языке паскаль записы выражения \frac{34,5+24,5}{15y}.а)34.5+24.5/15у в)(34.5+24.5)/15у с)(34.5+24.5)15*у.д)(34.5+24.5)/(15*у).3)Вычислите длину окружности и площадь круга одного и того же заданного радиуса R.4)Даны два числа.Найдите среднее арифметическое кубов этих чисел и среденее геометрическое модулей этих чисел.Два последних номера там нужно написать программу,программу присылать на листочке

Помогите, пожалуйста, очень нужно! Срочно!:( 1) Не используя функцию возведения в квадрат, напишите на языке Паскаль наиболее короткие алгоритмы

вычисления: а) y=x^10 б) y=x^15. Постараться использовать минимальное количество дополнительных переменных. 2) Дана сторона равностороннего треугольника. Найти площадь этого треугольника, его высоты, радиусы вписанной и описанной окружностей. Программу записать на языке Паскаль. 3) Дана величина А, выражающая объём информации в байтах. Перевести А в более крупные единицы измерения информации. Программу записать на языке Паскаль

2. Определить, делится ли введенное число "а" на 3. Если делится то вывести на экран "Число делится на 3".Тип переменной определить самостоятельно. При

составлении условия учесть, что если число делится на 3, то то остаток от деления на 3 должен быть равен 0.

3. Дана программа на языке Паскаль.
var a,n,s: integer;
begin
s:=0;
n:=0;
repeat;
write('Введите число ');
readln(a);
s:=s+a;
n:=n+1;
until s>100;
writeln('Количество введенных чисел = ' ,n);
end.
Переписать программу используя цикл While.

4. Вывести на экран массив целых чисел, Состоящий из 15 элементов, значение которого из которых сгенерировано случайным образом из диапазона [20,60].

Очень надо!! пожалуйста)Составить программу на языке Pascal, которая позволяет ввести с клавиатуры целое трехзначное число, проверяет, симметрично ли оно,

и печатает сообщение на экране. (Трёхзначное число симметрично, если крайние цифры числа одинаковые)

Дан массив с 10 числами ( любой диапазон с отрицательными числами)

Необходимо посчитать элементы массива значения которых кратно 2. Заменить элементы массива значения которых отрицательны,заменить числом 111
Напишите программу пожалуйста на языке паскаля



Вы находитесь на странице вопроса "Программа на языке паскаль сравнить 2 числа а и б если число а&gt;б, то тогда б=а2", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.