Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Дан массив, заполненный значениями скоростей разных марок автомобилей. Определить 2 самых быстрых автомобиля (2 самых медленных).

5-9 класс

Polinapolik93 01 дек. 2016 г., 20:56:23 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Dika2
01 дек. 2016 г., 23:26:52 (7 лет назад)

Program Pr1;
uses crt;
const n=100;
var mas:array[1..n] of integer;
var g,i,h:integer;
Begin
clrscr;
for i:=1 to n do begin
writeln('введите скорость ',i,' -ого автомобиля');
readln(mas[i]);
end;
for g:=1 to n-1 do
for i:=1 to n-g do if mas[i]<mas[i+1] then begin
h:=mas[i];
mas[i]:=mas[i+1];
mas[i+1]:=h;
end;
for i:=1 to 2 do writeln(mas[i]); {максимальные скорости}
for i:=n-1 to n do writeln(mas[i]); {минимальные скорости}
end.

Ответить

Другие вопросы из категории

8. B 2 . В программе «:=» обозначает оператор присваивания, знаки «+», «-», «*» и «/» — соответственно операции сложения, вычитания, умножения и деления.

Правила выполнения операций и порядок действий соответствуют правилам арифметики. Определите значение переменной a после выполнения алгоритма:
а := 2 b := 4b := a/2*b a := 2*а + 3*b
В ответе укажите одно целое число — значение переменной a.

Читайте также

Решить задачи на языке программирования в Turbo Pascal: 1) Дан массив, состоящий из 10 чисел, значения могут быть

от -100 до 100. Определить минимальное положительное число.

2) Дан массив, состоящий из 10 чисел. Найдите номера тех элементовв масива, которые наименее различаются.

1). Дан массив из n элементов (n >= 4). Подсчитать среднюю арифметическую второго и предпоследнего элемента массива.

2). Дан массив из n элементов. Написать программу подсчитывающую произведение элементов массива.

1)дан массив. найти сумму положительных и нечетных и количество отрицательных четных элементов

2)Дан массив целых чисел.Найти сумму четных положительных чисел, стоящих на нечетных местах и количество отрицательных элементов, стоящих на четных местах.
3)дан массив целых чисел.найти сумму четных и положительных элементов, расположенных до первого отрицательного элемента.Примечание:при вводе необходимо учесть, что первый элемент не может быть отрицательным.

1.Дан массив целых чисел, найти среднее арифметическое всех элементов массива.

2. Дан массив целых чисел,найти количество отрицательных элементов массива.
3. Дан массив целых чисел,найти количество чётных чисел в массиве.

1.Дан массив целых чисел из 25 элементов. Заполнить его случайными числами до 50. Найти сумму всех четных элементов массива и их количество.

2.Дан массив целых чисел из 25 элементов. Заполнить его случайными числами от 0 до 50. Заменить все четные элементы на их квадраты, а нечетные удвоить.



Вы находитесь на странице вопроса "Дан массив, заполненный значениями скоростей разных марок автомобилей. Определить 2 самых быстрых автомобиля (2 самых медленных).", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.