Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Паскаль. Вводится восьмизначное число. Поменять в нем соседние цифры.

10-11 класс

Помогите решить задачу.

Borkovecz 16 сент. 2013 г., 6:19:19 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Julliannkaaaa
16 сент. 2013 г., 9:08:11 (10 лет назад)

var i,n:integer;s1,s2,s3:string;
a:array [1..100] of integer;
begin
write('Введите Число: ');
readln(n);
str(n,s1);
if length(s1)=8 then begin
for i:=1 to 7 do begin
s2:=copy(s1,i,1);

s3:=copy(s1,i+1,1);
delete(s1,i+1,1);
delete(s1,i,1);
insert(s3,s1,i);
insert(s2,s1,i+1);
i:=i+1;
end;
end;
writeln(s1);
end.

Ответить

Другие вопросы из категории

Вводится последовательность из N положительных целых чисел. Найти

наименьшее число среди чётных элементов последовательности.

А= 10001,01

В=001011,010 в двоичной системе. Выполните сложение и вычитание с этими числами А-В, А+В

Читайте также

1)По данному числу n вычислите сумму 2(1-1/3+1/5-1/7+...+(-1)n/(2n+1)). Формат входных данных: Вводится одно число n, не превосходящее 100000.

Формат выходных данных: Необходимо вывести значение выражения 2) Вводятся 4 числа: a, b, c и d. Выведите все числа на отрезке от a до b,не дающие остаток c при делении на d 3) Подсчитайте, сколько среди данных N чисел нулей, четных чисел, нечетных чисел. Вводится число N, а затем N чисел. Необходимо вывести сначала число нулей, затем число четных и нечетных чисел 4) электронное устройство, выдает каждую секунду очередное число последовательности 1, 2, 2, 3, 3, 3, 4, 4, 4, 4, 5... Ввиду дороговизны электронных комплектующих вам поручено разработать эмулятор для этого устройства. Формат входных данных: Дано количество секунд (от 1 до 1000000), которые работает генератор после включения. Формат выходных данных: Результат работы генератора(пример 2 1 2 5 1 2 2 3 3) 5)Вклад в банке составляет x рублей. Ежегодно он увеличивается на p процентов, после чего дробная часть копеек отбрасывается. Каждый год сумма вклада становится больше. Определите, через сколько лет вклад составит не менее y рублей.Программа получает на вход три натуральных числа: x, p, y и должна вывести одно целое число 6)Исполнитель “Раздвоитель” преобразует натуральные числа. У него есть две команды: “Вычесть 1” и “Разделить на 2”, первая команда уменьшает число на 1, вторая команда уменьшает число в два раза, если оно чётное, иначе происходит ошибка.Дано два натуральных числа A и B (A>B). Напишите алгоритм для Развоителя, который преобразует число A в число B и при этом содержит минимальное число команд. Команды алгоритма нужно выводить по одной в строке, первая команда обозначается, как -1, вторая команда как :2.

1.пользователь вводит натуральное число. Определить среднее арифметическое цифр этого числа.

2.пользователь вводит натуральное число N. Найти сумму всех натуральных чисел от 1 до N.

1) Вводится 4 числа. Вывести на экран наибольшую из первых цифр заданных чисел. Например, если a=46, b=831, c=2996, d=486, то напечатать число 8.

Использовать процедуру. - Написать на Паскале.

2) Дан массив A(10,5). Поменять местами элементы первого столбца с элементами столбца, в котором находится максимальный элемент массива. - Написать на Паскале.

3) Вводятся значения трех переменных. Переставить значения. Дополнительные переменные не использовать.
Составить алгоритм.



Вы находитесь на странице вопроса "Паскаль. Вводится восьмизначное число. Поменять в нем соседние цифры.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.