Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Дано произвольная символьная строка.Узнать её длину и удалить 1,2 и 3 символ ивывести на экран.Pascal.

5-9 класс

Haloo35 22 дек. 2013 г., 15:07:49 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Nfyzkepbyf
22 дек. 2013 г., 15:57:13 (10 лет назад)

var
a:string;
l:integer;
begin
readln(a);
l:=length(a);
Delete(a, 1, 3);
writeln('dlina=', l);
writeln(a);
end.

+ 0 -
Lerok20121
22 дек. 2013 г., 16:48:15 (10 лет назад)

var

  a: string;

  

begin

  writeln('Введите строку');

  readln(a);

  writeln('Длина исходной строки равна:  ', length(a));

  Delete(a, 1, 3);  //Удаляем из строки a 3 символа, начиная с 1 позиции

  writeln('Полученная строка: ', a);

end.

Ответить

Другие вопросы из категории

Читайте также

помогите пожалуйста. 1) Дано слово.Заменить каждый "нечетный" символ на пробел. 2)Дана символьная строка. Определить какая буква встречается

раньше: "x" или "e" ? 3) Дана символьная строка . Определить будет ли произведение цифр нечетным числом?

Помогите по программе paskal : 1.дано целое число.напишите программу которая уменьшает на 2 модуль этого числа и выводит на экран монитора

результат

2.дано целое число.напишите,программу которая выводит на экран последнюю цифру данного числа,затем возводит ее в квадрат и выводит на экран монитора результат

дано натуральное число N, Написать ему выводящую на экран последовательность натуральность натуральных чисел от 1 до N, задание 2 дано натуральное число

N, Написать ему выводящую на экран последовательность натуральность натуральных чисел отN до 1, номер 3 Даны натуральные числа N и К.Написать программу выводящую на экран последовательность из N чисел , каждое из которых равно К хотя бы что нибудь решите помогите очень надо!!!!!!!!!

1. Запишите определение алгоритма, вставив пропущенные слова:«Алгоритм – это … и … предписание исполнителю выполнить … последовательностькоманд,

приводящую к … ».2. Структура алгоритма, все команды которого выполняются по очереди только один раз,называется:а) Линейной.б) Ветвящейся.в) Циклической.г) Рекурсивной.3. Свойство алгоритма содержать только те команды, которые понятны исполнителю,называется:а) детерминированностью;б) массовостью;в) понятностью;г) однозначностью.4. Как называется свойство алгоритма, в котором отражено четкое разделение шагов и ихпоследовательное выполнение:а) однозначность;б) результативность;в) понятность;г) дискретность.5. Как называется алгоритмическая конструкция, в которой, в зависимости от условий,может выполняться либо одно, либо другое действие?а) Линейной.б) Ветвящейся.в) Циклической.г) Рекурсивной.6. Исполнитель Черепашка перемещается на экране компьютера, оставляя след в виделинии. В каждый конкретный момент известно положение исполнителя и направление егодвижения. У исполнителя существуют две команды:Вперед n, где n – целое число, вызывающая передвижение черепашки на n шагов внаправлении движения.Направо m, где m – целое число, вызывающая изменение направления движения на mградусов по часовой стрелке.Запись Повтори 4 [Команда 1 Команда 2] означает, что последовательность команд вквадратных скобках повторится 4 раза.Черепашке был дан для исполнения следующий алгоритм:Повтори 4 [Вперед 10 Направо 120]Какая фигура появится на экране?1) незамкнутая ломаная линия в) квадрат2) правильный треугольник г) правильный пятиугольникПримечание: сумма внешних углов правильного n-угольника равна 360 градусов.7. Определите значение переменной а после исполнения алгоритма.а:=6b:=22-3*aa:=b/2*aПорядок действий соответствует правилам арифметики. В ответе укажите только одно число.8. Определите значение переменной b послевыполнения алгоритма, записанного в видеблок-схемы:Примечание: знаком := обозначенаоперация присваивания. В ответе укажитеодно число – значение переменной b.9. У исполнителя Калькулятор две команды, которым присвоены номера:1. прибавь 22. умножь на 3Первая из них увеличивает число на экране на 2, вторая – утраивает его. Запишитепорядок команд в алгоритме получения из числа 1 числа 31, содержащем не более 5команд, указывая лишь номера команд (например 22211).10. Некоторый алгоритм из одной цепочки символов получает новую цепочку следующимобразом. Сначала записывается исходная цепочка символов, после нее записываетсябуква, стоящая в исходной цепочке на первом месте, затем записывается исходнаяцепочка символов в обратном порядке. Получившаяся цепочка является результатомработы алгоритма. Например, если исходная цепочка символов была ЛЕС, то результатомработы алгоритма будет цепочка ЛЕСЛСЕЛ.Дана цепочка символов ЗУ. Какая цепочка символов получится, если к данной цепочкеприменить алгоритм дважды (то есть к данной цепочке применить алгоритм, а затем крезультату его работы еще раз применить алгоритм)?11. На бесконечном поле имеется бесконечная стена. Робот (Р) находится над стеной исмотрит вправо. Написать алгоритм, который переведет Робота в первую клетку подстеной (к.с.).Рк.сПримечание: команды, которые умеет выполнять Робот, узнайте у преподавателя.

Сформируйте массив bc размерностью30 элементов случайным образом из диапазона 0 – 50.сформированный массив выведите на экран в строку. Подсчитайте

сумму всех четных элементов массива и отдельно сумму элементов имеющих четные индексы. Выведите результаты подсчета на экран. Отсортируйте данный массив по убыванию.



Вы находитесь на странице вопроса "Дано произвольная символьная строка.Узнать её длину и удалить 1,2 и 3 символ ивывести на экран.Pascal.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.