Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

ЛЮДИ, ПОМОГИТЕ, ПОЖАЛУЙСТА Найти значения минимального элемента одномерного целочисленного массива, сформированного пользователем, и его индекс.

5-9 класс

Внимание, предусмотреть ситуацию нескольких элементов с минимальным значением. В этом случае вывести на экран все индексы. Паскаль.

Asmarasya95 24 июня 2013 г., 22:58:50 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
катюсенька
24 июня 2013 г., 23:36:40 (10 лет назад)

var
mas:array[1..10] of integer;
i,min:integer;
begin
min:=maxint;
for i:=1 to 10 do
begin
readln (mas[i]);
if (mas[i]<min) then min:=mas[i];
end;
writeln ('Минимальный элемент массива =',min);
for i:=1 to 10 do
if (mas[i]=min) then writeln ('Индекс минимального элемента: ',i);
end.

Ответить

Другие вопросы из категории

помогите вставить названия устройств. я включил компьютер и набрал на клавиатуре сочинение про свою семью. Затем я переписал с фотоаппарата последние

фотографии добавил их к тексту и вывел сочинение на монитор. После этого я прибавил громкость звука колонок и стал играть в любимую игру, быстро двигая мышь. получив рекордный результат, я ввёл с ............(10 букв) своё имя и распечатал на принтере рекордсменов

Метеорологическая станция ведет наблюдения за влажностью воздуха. Результатом одного измерения является целое число от 0 до 100 процентов, которое

записывается цепочкой из нулей и единиц минимальной длины, одинаковой для каждого измерения. Станция сделала 8192 измерения. Определите информационный объем результатов наблюдений.

Читайте также

составьте программу которая запрашивает значения элементов одномерного числового массива а, стоящего из 10 элементов,формирует и выводит на экран в

строку данный массив. Найти сумму неположительных элементов массива,количество элементов кратных 3, произведение элементов,стоящих на четных местах

Помогите пожалуйста ! срочно надо!!!...в заданной последовательности целых чисел определите сумму элементов кратных 10! пример задачки вот именно под

типо по такой же системе которую щас напишу! program Maximum; i,n,max:integen; begin writeln ( 'введи элементы массива для поиска максимума'); for i:=1 to 10 do begin write ('a [', i ,']=');readln (a [ i ] ) ;end; max:=a[1]; for i = 2 to 10 do if a [ i ] > max then begin max:=a [ i ] ; n:= i ; end; writeln ('найти наибольший элемент ',max ,' под номером ', n); вот наподобие этого примера нужно построить мою задачу! в заданной последовательности целых чисел определите сумму элементов кратных 10. Помогите пожалуйста!!!

Помогите, пожалуйста, решить задачу на языке программирования в Turbo Pascal: 1.Дан массив целых чисел, состоящий из 10 элементов.Заполнить его

с клавиатуры. Найти:
-Удвоенную сумму положительных элементов;
-вывести индексы тех элементов, значения которых больше значения предыдущего элемента(начиная со второго).

2.Определить,есть ли 2 пары соседних элементов с одинаковыми знаками.



Вы находитесь на странице вопроса "ЛЮДИ, ПОМОГИТЕ, ПОЖАЛУЙСТА Найти значения минимального элемента одномерного целочисленного массива, сформированного пользователем, и его индекс.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.