Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Var x,y:integer;

10-11 класс

function nod(x:integer):Longint;
begin
if x=0 then nod:=1
else nod:=nod(x-1)*x

поясните последние две строчки плз

Shulika12 12 марта 2014 г., 8:57:18 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Diana05re
12 марта 2014 г., 10:49:09 (10 лет назад)


А что объяснять то  ? В случае если на функцию подается число 0 - её значение будет равно 1, если же подается значение отличное от 0 - Начинается последовательное вызывание функций по нисходящей nod(x), nod(x-1) и  т.д. причем это все домножается на х. В конечном итоге это факториал числа X

Ответить

Другие вопросы из категории

Напишите программу, которая в последовательности натуральных

чисел определяет сумму чисел, кратных 3. Программа получает на
вход количество чисел в последовательности, а затем сами числа. В
последовательности всегда имеется число, кратное 3.
Количество чисел не превышает 100. Введённые числа не превышают 300.
Программа должна вывести одно число – сумму чисел, кратных 3.

Датчиком случайных чисел

сгенерируйте натуральное число в интервале от 100 до 900. Найдите трехзначное
число, состав ленное из тех же цифр, но записанных в обратном порядке.

Пожалуйста, помогите!! Спасибо большое :)

Данную задачу:

Для
записи текста использовали 256-символьный алфавит. Какой объём информации в
байтах содержат 15 страниц текста, если на каждой странице расположено 32
строки по 64 символа в строке?

Нужно оформить в таком виде (записи):

2i=? => ? символ=? бит

В компьютерной фирме "кака-ду" трудятся 27 работников. Новому году директор решил шести работникам не давать премии.Сколькими способами директор может

выбрать людей , которые получат премию из всех сотрудников фирм.В ответе укажите только число?

У кати есть доступ в интернет по высокоскоростному одностороннему радиоканалу, обеспечивающему скорость получения информации 220 бит в секунду. У

Сергея нет скоростного доступа в Интернет, но есть возможность получать информацию от Кати по телефонному каналу со средней скоростью 2 13 бит в секунду. Сергей договорился с Катей, что она скачает для него данные объемом 9 Мбайт по высокоскроростному каналу и ретранслирует их Сергею по низкоскоростному каналу. Компьютер Кати может начать ретрансляцию данных не раньше, чем им будут получены первые 1024 Кбайт этих данных. Каков минимально возможный промужеток времени (в секундах) с момента начала скачивания Катей данных до полного их получения Сергеем?

Читайте также

15. Определите

результат выполнения программы:


var
i, sum: integer;

Почему на этапе ввода последней ступени (т.е. задали х=5 и вводим 5 ступень) паскаль выкидывает ошибку: "Индекс находился вне границ массива", ведь al[x]

это его последний элемент, разве нет?
Код:

program s1;
var x, i:integer;
al, tl: array of real;
begin
writeln ('Введите количество ступеней ракеты'); read (x);
setlength (al, x);
setlength (tl, x);
for i:=1 to x do begin
writeln ('Введите ускорение ', i, ' ступени'); read (al[i]);
writeln ('Введите время работы ', i, ' ступени'); read (tl[i]);
end;
end.
P.S.: Переписать массив в статический не предлагать, нужен именно переменной длины. Заранее спасибо.



Вы находитесь на странице вопроса "Var x,y:integer;", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.