Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Составить алгоритм

5-9 класс

Для заданных значений x, a, b вычислить значение y

ЯнкаВ 14 марта 2014 г., 20:09:34 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Jonni121
14 марта 2014 г., 21:43:30 (10 лет назад)

Вроде так, но программа немного странная
var
x,a,b,y:integer;
begin
read(x,a,b);
if x<>0 then y:=0;
if (x=0) and (a=0) then y:=1;
if (x<>0) and (x=b) then y:=2;
if (x=a) or (x=b) then y:=3;
writeln(y);end.

Ответить

Другие вопросы из категории

8 класс.

Определите значение переменной A после выполнения алгоритма . Составить трассировочную
таблицу. Порядок действий соответствует правилам арифметики.
A:=4+7*3
C:=5+A/5
B:=6+C/2
A:=B-C/2+A*4/5

Какое расширение имеет текстовые файлы? (выберите верный ответ)

1 exe, bat, com
2 ppt, pps
3 rtf, doc, docx, txt
4 avi, wmv, mpeg

Читайте также

Составить алгоритм нахождения площади и длины окружности если известен радиус.

Составить алгоритм нахождения площади и длины окружности если известен диаметр.

Умоляю помогите,мне нужно составить Алгоритм своего имени ,зовут меня Нурлан

Мне необходимо составить алгоритм каждой буквы : н,у,р,л,а,н
Примерно алгоритм выглядит вот так- Поднять перо. Сместиться в точку.Опустить перо.Сместиться на вектор.
Составьте хотя бы алгоритм буквы Н

1) Составить алгоритм выхода на улицу в зависимости от погодных условий.

2)Составить алгоритм кипячения воды а чайнике с помощью электроплиты.

Пожалуйста,мне нужно составить Алгоритм своего имени по Информатике

Алгоритм выглядит примерно так- Сместиться в точку ....
Опустить перо
Сместиться на вектор ...

Моё имя-Нурлан
Пожалуйста кто сможет напишите ) Заранее большое спасибо вам

Составьте алгоритм вычисления суммы всех

натуральных чисел, не превышающих заданного натурального числа N.
Проверьте алгоритм трассировкой. Напишите программу на Паскале.



Вы находитесь на странице вопроса "Составить алгоритм", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.