Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Помогите создать программу в паскале, которая сможет найти количество нечетных элементов массива!!) Срочно!!) Заранее спасибо!)

5-9 класс

var a:array [1..20] of integer;

Magomedova23035 30 янв. 2015 г., 16:28:48 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Lizalizalizaliz1
30 янв. 2015 г., 17:23:47 (9 лет назад)

Program P;
var i, s, elem: integer; a: array [1..20] of integer;
BEGIN
 s := 0;
 FOR i := 1 TO 20 DO
 BEGIN
   IF (a[i] mod 2 = 1) THEN s := s + 1;
 END
  writeln('Число нечетных элементов', s)
END;
END.

Ответить

Читайте также

1.Дан массив целых чисел, найти среднее арифметическое всех элементов массива.

2. Дан массив целых чисел,найти количество отрицательных элементов массива.
3. Дан массив целых чисел,найти количество чётных чисел в массиве.

Помогите написать программу на Паскале.

Напишите программу, которая в последовательности целых чисел
вычисляет сумму всех чисел, которые кратны 6 или 11. Программа получает на вход
целые числа, количество введённых чисел неизвестно, последовательность чисел
заканчивается числом 0 (0 – признак окончания ввода, не входит
в последовательность).

Количество чисел не превышает 1000. Введённые числа по
модулю не превышают 30 000.

Программа должна вывести одно число: сумму всех чисел,
которые кратны 6 или 11.






ПОЖАЛУЙСТА!!! Помогите ребята!!! Моя Оценка на ваших руках!!! Я нифига не могу сам делать!!! У нас професор самый левый!!! Нечего не обьясняет!!! ПРОШУ!!!

Создайте программ в ПАСКАЛЬ который считывает из текстового файла DATE.IN по одному номеру из 4 цыфры из каждой линии, и создает другой текстовый файл DATE.OUT
где записывает только номера "хорошо упорядоченные". На экране должно отображаться количество таких цыфр.

Хорошо упорядочнные - Это те номера у которых цыфр 1 2 3 7 9 12, 16 ... (строго возрастают) или у которых цыфр 17 14 8 5 4 2 1 (строго уменьшаются)

ЗАРАНЕЕ СПАСИБО!!! Только 25 очков!!! Имел бы больше!!! Всех бы поставил!!!

Создать программу в Паскале, 9 класс

Поменять местами первый элемент масива и максимальный.
Заранее Спасибо) Помогите пожалуйста) Очень срочно!!)
var a: array [1..20] of integer;



Вы находитесь на странице вопроса "Помогите создать программу в паскале, которая сможет найти количество нечетных элементов массива!!) Срочно!!) Заранее спасибо!)", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.