Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Помогите с паскалем, у меня практика, это очень срочно...

10-11 класс

1. Вычислите выражение при заданных константах: A=16.5; b=3.4; x=0.61; S=x^3tg^2(x+b)^2+a/√x+b; Q=bx^2-a/e^a^x-1





2.

Составить программу вычисления значения функции. На экран вывести функцию (записанную на Паскале) вместе с результатом.


у={a+b+cx^2,если 1<=x<2
(a*sin(xb))^2,если 2<=x<3
под корнем |a+bx^2|+c ,если 3<=x<4
a*ln|b+c/2x| ,если 4<=x<5
e^esinx+c^3 ,если 5<=x<6


Пожалуйста...

Pavel262003 14 июня 2014 г., 19:23:12 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Cat1414
14 июня 2014 г., 20:18:36 (9 лет назад)

1)
uses crt;
const a=16.5;b=3.4;x=0.61;
var s,q:real;
begin
s:=x*x*x*(sin((x+b)*(x+b))/cos((x+b)*(x+b)))*(sin((x+b)*(x+b))/cos((x+b)*(x+b)))+a/sqrt(x+b);
q:=(b*x*x-a)/(power(e,a*x)-1);
writeln('s: ',s:0:4,' q: ',q:0:4);
end.
2)
uses crt;
const a=16.5;b=3.4;
var f,c,x:real;
begin
writeln('Введите c,x:');
read(c,x);
if (x<1) or (x>=6) then
writeln('NULL')
else if (x>=1) and (x<2) then
f:=a+b*x+c*x*x
else if (x>=2) and (x<3) then
f:=(a*sin(x*b))*(a*sin(x*b))
else if (x>=3) and (x<4) then
f:=sqrt(abs(a+b*x*x)+c)
else if (x>=4) and (x<5) then
f:=a*ln(b+c/(2*x))
else if (x>=5) and (x<6) then
f:=power(e,e*sin(x))+c*c*c;
writeln(f:0:4);
end.

+ 0 -
3790
14 июня 2014 г., 23:08:51 (9 лет назад)

А c откуда брать? Константы c нету.

+ 0 -
тезя
15 июня 2014 г., 0:35:22 (9 лет назад)

Не знаю... Все что было написала.

+ 0 -
Batonstrelkov
15 июня 2014 г., 2:21:59 (9 лет назад)

Ладно, сделаю ввод "c" с клавиатуры, раз данных о ней нет.

+ 0 -
Volhok1996
15 июня 2014 г., 4:08:51 (9 лет назад)

И x, видимо, тоже надо считать, т.к. он не попадает в данный диапазон [1;6)

Ответить

Другие вопросы из категории

Помогите , пожалуйста !!!

Растровый графический файл содержит черно-белое изображение ( без градации серого ) размером 400 на 250 точек . Каков информационный объем этого файла ? ( в Кб)

Напишите оператор присваивания, в результате выполнения которого целой переменной н присвоится значение цифры, стоящей в разряде сотен в записи

положительного целого числа к ( например, если к= 28796, то н= 7).
p.s язык Паскаль:)

Читайте также

Помогите пожалуйста)

Нужно составить в паскале программу для проверки пароля, совсем не понимаю паскаль, для меня это темный лес!)

Помогите, пожалуйста!! Язык программирования Паскаль.

1) Найти количество отрицательных элементов в массиве А [3,8].
2) Заполнит и вывести массив Р [6,7], запросить номер строки и вывести её на экран.
3) Заполнить и вывести массив Р [6,7], запросить номер строки, заменить все её элементы на 5 и вывести новый массив.
4) В квадратной матрице А [10,10] заменить элементы главной диагонали на 0.

Всё нужно очень срочно



Вы находитесь на странице вопроса "Помогите с паскалем, у меня практика, это очень срочно...", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.